Peugeot Forums banner

1 - 20 of 42 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Hi all I'm new here so dont know what's been posted and what hasn't. I'm new to peugoet and I've recently just brought a 1.4 petrol 2007 plate.

Well I'm having big problems with it right now like when its sat idling its revving its self then after about 10 mins it just cuts out and I turn the key and its starts up again with no problems.

I can drive it down the road and I get a couple of errors pop up on the dash one is electrical fault another is anti pollution fault I have a triangle come up and the engine light comes on then I will get the abs light flash on and off then the car just dies and when I try to restart the car it acts like the battery is dead if I leave it for a min it will start up like normal and I can drive it again with no problems for around 10 mins and then it will happen again.

I have had the codes read and I get q few codes which are,
P0341 powertrain
Camshaft position sensor A (bank 1)
P0012 powertrain
A camshaft position timing over retarded (bank 1)
P0011 powertrain
A camshaft position timing over advanced (bank 1)

Can anyone help me with this please. I'm guessing I need a new camshaft sensor? But I've read that the modal of my car doesnt have a camshaft sensor? If it does could anyone tell me where it is located?

Thanks
 

·
Registered
Joined
·
1,930 Posts
I would say first off get your battery load tested as Pugs are very sensitive to poor electric supply. You can buy a meter that does it for not a lot of money and it also reads the voltage and charge voltage. Or you could take it to a independent garage or battery supplier and they would probably test it for you free if they think they are going to have a paying customer. The alternator when charging the battery should be showing 14 volts output. Once you have sorted that one way or another let us know and we can then give you a better chance of advising the problem.
Ebay item no 322657736823 is the type I use It has a heat sink and is easy to use.
 

·
Moderator
Joined
·
11,809 Posts
first thing you need is an independent diagnostic from one of us



 

·
Registered
Joined
·
22 Posts
Discussion Starter #4
Gibbo and how much would that cost? I dont know any Peugeot specialists where I live aka east coast of uk skegness
 

·
Registered
Joined
·
22 Posts
Discussion Starter #7
Ok so the battery has been fully tested and everything is fine which I thought it would be because the battery is only about 6 months old.

So can anyone at all help me with the problems I have listed, i cant afford to take it to a garage at the moment so any help will be great

Thanks.
 

·
Registered
Joined
·
1,930 Posts
OK. Is there any history with the car. I.e. past Mots, service history, mileage etc. Every titbit of info helps when trying to diagnose blind. I would have a look at the ECU for signs of water ingress. It is located at the left hand side front of the car.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #9
Only history I have is the advisories from mot is slight oil leak and slight exhaust leak. I have one receipt saying the clutch and brakes have been done that was around 3 months ago and it's on around 106k miles
 

·
Registered
Joined
·
22 Posts
Discussion Starter #12
Ok so heres my exu as you can see nothing wrong there looks perfectly fine and dry
87499
 

·
Moderator
Joined
·
5,967 Posts
which 1.4 engine if its a VTI check the VTI solenoids and cam chain
 

·
Registered
Joined
·
22 Posts
Discussion Starter #18
Ok so I've checked all the plugs in the fuse box checked all the fuses everything looks fine. Altho it looks like the ecu has been changed at some point because someones marked the plugs and points with tip ex
 
1 - 20 of 42 Posts
Top