Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1 (Edited)
Peugeot expert E7 power problems.

Hi guys,

I have a peugoet E7 taxi that loses power,

The turbo works but.. The mid range before the turbo comes in is lacking bad.

Its as if the turbo boost comes in too late.

Have changed a few electro valves as they are called but it still plays up.

It has stopped smokling when driving (used to smoke alot) and now smokes on tick over where it never used too.

It has been using silly amounts of fuel ( will need to tow a fuel bowser behind me soon)

Any help or advice will be great.
 

·
Registered
Joined
·
15 Posts
sounds like ecu fault try looking for a wire that comes from an injector may be broke but first off i'd get it on a snapon scanner where abouts are you mate
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
I have rectified the problem at present.

Mass air flow meter was giving a false reading but showing it was working.

So I changed that at an expense of £115 inc VAT.

And it still now seems to be running ok.

(So it may be an idea if anyone else has this problem and the computer reads a reading to check it with another MAM )

Thanks for all help given .
 

·
Registered
Joined
·
5 Posts
Please help with peugeot expert e7 se

Hi Guys hope everyone is well, I am having nightmares with my peugeot expert e7 se 54 plate, and im losing hope it seems like the never ending story. It has problems with loss of power. Going up hill or up road i can barely pick up any speed it struggles, on motorways its very slow I barely manage 70+ and that too with great effort. The accelerator has to be lightly pressed for power to kick in and after a while it does, pressing fully down does not achieve anything. Occasionaly the engine management light would appear, maybe one a day or soemtimes two days depepnding how much I drive when It does it jerks.

So far I have had the air flow meter changed, tried a few different vaccum valves, and been to a few mechanics. One guy had it diagnosed by launch it read " Intermitent fault injecter one open circuit, battery too low harness resistance ", a few days after driving it wouldnt acelerate in the morning and was contineously jerking, a mate came and touched the injector wiring pushed it in and it was fine. Bu the speed problem is still there, i thought i'd get the injector reconditioned, or change the wiring but before doing so i thought it wud be handy taking it to peugeot. Today the dignostic was carried out, first he said the injector appaered then he cleared it and tested again and it dissappeared other diagnostic guys have done the same it keeps appearing eventually. Peugeot report read " Various intermitent faults in memory , turbo not working correctly, further investigation required to see if turbo is faulty or if a vaccum valve is at fault", I have also changed the turbo sensor. It does drink fuel id say but not awfully bad.

Can soemone please help I wonder if taximan pete had simmilar problems, I just wnat to get this sorted i dont knwo what to do.
 

·
Registered
Joined
·
7 Posts
Hi Can you get in touch please,

Im currently in the process of dealing with a claim with cab direct and peugeot, i would like to have some help and information to strengthen my case.

Please can you get in touch with on [email protected]
 
1 - 8 of 8 Posts
Top