Peugeot Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Hi I am looking to convert my 2.0 16v e7 to an 8v engine as I have a non runner 16v and a perfectly good rear end smashed 8v.
Engine gearbox driveshafts and ecu being the obvious things to change .Am I missing anything and is there any pitfalls I should be aware of . Any help appreciated cheers :confused::thumb:
 

·
Moderator
Joined
·
5,067 Posts
Reliable406 is probably your best man for info on this, he will hopefully be along soon
 

·
Registered
Joined
·
15,377 Posts
Swap everything over engine wiring loom for engine ecu and code box under dash with key and it should be easy enough gearbox same as are shafts exhaust downpipe different depending on turbo best use 8 valve one to be sure its right.

Some pipework differences for rad but only minor.

Blocks are actually the same casting only crank pistons and heads differ.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #6
Went to start my project today and discovered the rhw 16v wasn't a 16v after all but an 8v rhx engine which was turning over but not starting so I put the diagnostic on and it had these stored codes-
P0380
P1112
P0235
P0245
P1517
P0340
P0191

I then cleared these codes and it came up with just p1107 then upon attempting to start up came these codes
P0380
P1107
P1108


Anyone any ideas I'm thinking maybe faulty loom and heater plug relay??
 

·
Registered
Joined
·
15,377 Posts
forget glowplug fault and indeed forget reading faults you need to read live data for fuel pressure cranking speed and cam and crank sync these are all that's needed anything else is extra and can be fixed once it runs
 

·
Registered
Joined
·
15,377 Posts
31 bar way too low needs 120 bar to start then it rises to 298 at idle

96 rpm also too low needs 250 rpm try towing it see if it goes if not I would then do a leakback test on injectors.

Is the tank pump priming ok ?
 

·
Registered
Joined
·
28 Posts
Discussion Starter #10
Taxi starts very easy on jump and drives perfect for a couple of mins then goes to limp mode and drives for about 5 mins then cut out started again on tow straight away and drove for about 2 mins jumped immediately again and reversed into drive and let it tick over for about 40 mins then turned of with key but again won't start with key. I noted down the live data at tick over and also with about 3000 revs while in the driveway
 

·
Registered
Joined
·
15,377 Posts
With that extra info I would be inclined to blame the engine wiring loom as the wires become rotten and brittle over time might also be worth changing the starter as they do get lazy.

Post up your idle readings
 

·
Registered
Joined
·
28 Posts
Discussion Starter #12
Engine speed 771rpm
Cam/crank sync yes
Measured fuel pressure 243 bar
Diff between measured fuel and fuel pressure -2bar
Diesel pressure reg 16%
Injector flow set point 7mm
Injector 1 -0.90
2. 0.82
3. 0.04
4. -0.12
Egr valve electro valve OCR 5%
Egr throttle 5%

After a slight rev the egr readings went 75% and 25% with the odd fluctuation back to 5%
 

·
Registered
Joined
·
15,377 Posts
Most of that looks ok.

EGR should change when revved

Injector corrections are all over the shop but unless a leak off test shows one to be duff I doubt they are the issue

Change the starter check main cables positive and negative see if it then starts.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #14
Removed starter had it bench tested and checked the main cables. Still turning on key but not trying to start it is as if immobiliser is on :confused::confused:
 

·
Registered
Joined
·
28 Posts
Discussion Starter #16
I'm staring it on a tow and it starts first try. Drives ok for about 200-300meters then goes into limp mode and will cut out after about 10-15 mins of driving. Starts again on tow first time but cuts out after maybe 5 mins.if left parked on tick over it has not cut out. Just won't start with key just turns and turns with out so much as a splutter
 

·
Registered
Joined
·
15,377 Posts
I would do a leak off test on the injectors as the running fuel pressure is a little low and this would also make it hard to start if they were leaking back too much.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #18
Finally got it going changed the high pressure pump and it started first time and engine management light went out as well had it out for a couple of drives and it's running sweet :thumb: just like to say a big thank you to reliable406 for all your input.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #20
Next problem not to far away unfortunately keeps going into limp mode can reset but after a few hours driving getting management light on again getting these codes p1107 p1402 p0243
doesn't feel like limp mode when light comes on at first but after a hour or 2 of driving with light on it starts to slow down on acceleration and feels like limp mode :confused:

Also seen a egr removal kit On eBay are these any good and do I have to get remap if I remove egr
 
1 - 20 of 20 Posts
Top