Peugeot Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello, I am new to this forum and looking for some help to fix my pug. Any help is welcome and I want to share my information as well.

I’ve got Peugeot 407 2.0 HDI with the depollution system faulty. Since that fuel consumption a bit increased and reveres sometimes dropping. After scanning with OBD2 scanner the following faults codes been found

P1435 – Additive system fault (unfortunately I can’t scan additive ECU)
P0461 - Fuel Level Sensor Performance
P2408 - Fuel Cap Sensor

After cleaning fault codes P1435 only comes on after engine start, but after few more starts and other two comes again.
I did research and it is linked to additive system. Is P2408 relative to P1435?

I noticed when I remove the fuel cap (both magnets present) and put it back the additive system pump starts work in about 5min and fluid goes to the fuel tank (as I have disconnected additive fluid pipe from fuel tank to check) is it mean that fuel filler cap sensor and cap is not faulty? So why I’ve got P2408? Or it is need replacing anyway
Also I have removed and checked additive system tank and it’s half full of fluid, so do not need to top up.

The other thing where is fuel level sensor in this model? Is it possible to replace it separately or it is integrated in fuel tank?

Does anyone have any ideas? Thanks
 

·
Registered
Joined
·
2 Posts
Hi!

I have a pug 407 1.6hdi dv6 and yesterday tested my pug scanner (Pug Planet 2k) From the info that i got with it, i think that it measures the weight of what's in the tank... I could be wrong, however it showed me that i have 0 gram of that additive, I didn't top up yet, so don't know if i'm right.

Hope that helps in some way...

Regards..
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
hi just for update, the multiplay fault seems caused by additive ecu fault.
does anyone know where is additive ecu in 407 2.0 hdi?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
denis_st said:
Hi!

I have a pug 407 1.6hdi dv6 and yesterday tested my pug scanner (Pug Planet 2k) From the info that i got with it, i think that it measures the weight of what's in the tank... I could be wrong, however it showed me that i have 0 gram of that additive, I didn't top up yet, so don't know if i'm right.

Hope that helps in some way...

Regards..
hi,

fuel sensor measures FUEL level in the fuel tank and it different to additive fluid tank which has integrated sensor. you probably run out of additive fluid, so need to top up 3 liters and reset additve system counters.
 
1 - 4 of 4 Posts
Top