Peugeot Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi all, few months ago i bought a peugeot boxer 2.2 hdi to turn into campervan,soon after it developed loss of power at around 3000 rpm with black gushing smoke, i managed to get it home but on way it started cutting out and i had to wait a few minutes start it drive a while then it would happen again anyways had the fault codes read said it was a few thing so had the injector done the deisel pump done and after that it wouldnt start fault code read was the imobiliser so had that wiped of ecu and shes up and running well so i thought was driving it home from garrage got in the motorway at around 65 nearly 3000 rpm a loud ticking sound with loss of power and black smoke gushing out again slow down or take it out of gear back to normall until i get back to or near 3000rpm and it happens again every time. Theres no lights cumming up on dash anymore so no fault codes to be read it drives perfect under 3000 rpm or close to it.the same happens if i rev it on a stand still it just starts to make a missing sound and black smoke again puzzling me took it to a few garages now but get a different answer everytime.any ideas would be much appreciated thanks in advance.
 

·
Registered
Joined
·
14,951 Posts
Try one of the ford transit forums as they share the 2.2 engine as its actually a ford engine and they are more plentyful in transits so you will get more info on the myriad of problems these engines suffer from.

Be warned there is not much good news :(
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Hi mate i done what you said and posted on a transit forum and got the reply of, they didnt use this engine in transits they use a 2.2 in the mk 7 onwards but different engine to this one.they said mine is a psa dw12 engine it uses a bosch edc15 fuel management system same engine goes in peugeot 607, 807, 4007 the citroen c5, c6, c8 and c crosser any help of anyone will be much apreciated. Ive attached a photo of my engine so its alot clearer what were talking about.kind regards
 

Attachments

·
Registered
Joined
·
14,951 Posts
OK that is a DW12 but its not the same as th c5 807 etc as they are 16 valve engines yours is 8 valve and van specific you did not say age of van i assumed later type boxer that does use transit engine.

You need to see the fuel pressure at 3k revs but its more likely loosing boost due to a vacuum issue as the turbo is vacuum controlled when the boost cuts the fuel does not hence the black smoke.

It is more like a 406 engine to be honest as it is a bigger version of the early DW10 engine and works in the same way with vacuum controlled wastegate and EGR system
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
Ok makes sense to me sorrybfor not puting year of van up my fault,were would you suggest i start how do check fuel pressure at 3000 rpm any advice much appreciated
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
Ive noticed a blow from around exhaust manifold would that cause it something ive overlooked
 

·
Registered
Joined
·
11 Posts
Discussion Starter #8
Ive found one on here in cardiff but i have to post more than 20 posts before i can message them think is name was ayel
 

·
Registered
Joined
·
11 Posts
Discussion Starter #11
Peugeot planet diag tomorrow thanks to ayel of here hope this finds the problem cant wait might get an answer to this headache of a van.
 

·
Registered
Joined
·
14,951 Posts
Planet cant check the vacuum side of things so you need a vacuum or boost gauge to check vac levels if diagnostics dont give you the answers.

Post up the live parameter readings at 3k revs and any fault codes
fuel pressure should be 300 bar at idle and climb to around 700 by 3k revs

Glow plug faults can be ignored for now
 

·
Registered
Joined
·
11 Posts
Discussion Starter #13
Ok ime getting a full check with print out so will post up results tomorrow if that dont show up anything, who would i get to do a vacume or boost gauge test i did check turbo and pipes from turbo to inlet manifold today at garage turbo seems fine all pipes were ok but did change a few that looked tired and a water pipe
 
1 - 13 of 13 Posts
Top