Peugeot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
1. NO REVERSE LIGHTS, checked fusebox all clear. problem started after clutch replacement and mechanic who fixed moved countries!!!! ?????

2.RED BATTERY LIGHT COMES ON AND OFF IN RAIN. had brand new alternator fitted 2010. ?????

3.SNAPPED WIRES ON BACK RIGHT DOOR. yellow and grey/black wire sheared on opening/closing of door. terminal blocked back together again, NO change to whatever it does (im presuming its to do with central locking??) ??????

ANY HELP MUCH APPRECIATED
 
C

·
Guest
Joined
·
0 Posts
Have you checked the reverse light switch i think its on the gearbox, which may have been disturbed during clutch repair / refit possibly not plugged back in??
 

·
Registered
Joined
·
31 Posts
Test switch or short reverse light wires together.
Does the belt slip in the rain ie is the guard missing and water getting on the belt?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
misc probs

i thought it may have been some switch/connection around the gear box,for reverse lights not to work, i hear its a bitch to get to.

also the belt/squeak issue can happen just with cold morning and no rain. im presuming damp and it is slipping, but another one where its a pain to fix, retension and all that.

actually just got it back from garage today, felt i been shafted £236 for front brakes fitted, last had done 3 years ago for £70 all in.

the joy of peugeot boxers eh!!
 

·
Registered
Joined
·
31 Posts
(£70 all in) they didn't do very much then
What did you have done to the brakes this time ie parts etc?
 
1 - 6 of 6 Posts
Top