Peugeot Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Ok folks got a s**t of a problem with my 807 2.0hdi had the dreaded solenoid problem AL4 gearbox, Slow to pick up the gears when driving it would change from 1st to 2nd and no drive just rev for a couple of seconds then pick up the drive. So changed the solenoids new oil to now i have 3 major problems ist is when i plug in the Peugeot diagnostics it wont read the gearbox ecu saying no com's to gearbox 2nd& 3nd is a fault coming up on the dash saying Speed control system faulty & ESP/ASR system faulty and they where not there before the solenoid change :mad::confused: attached 3 pic's i hope
 

Attachments

·
Registered
Joined
·
14,961 Posts
Ok the speed signal fault could be the speed sensor for the gearbox this is because the gearbox ecu is not present on the network check the power and earths for the gearbox ecu if it has no power it wont show on network and it also wont allow you to read it.

Check the plug on the gearbox too it may have a dirty connection and the earths near the ecus.
 

·
Registered
Joined
·
1,054 Posts
Check the brake fluid level as well, I get an ESP warning when it's low. Yes it will take you ½ hour to dismantle enough to reach it!
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8 (Edited)
thanks both ill check in the morning and let you no, iv got the air cleaner for the cabin still off so will be a bit easer get to the brake fluid. thanks again a happy new year to all the members
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
Ok sorry its been a few days not been well at all. Iv checked the plug on the gearbox and all the earth's and brake fluid level ok I'm wondering now if it the throttle position sensor playing up :confused:
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10 (Edited)
Ok folks got a s**t of a problem with my 807 2.0hdi had the dreaded solenoid problem AL4 gearbox, Slow to pick up the gears when driving it would change from 1st to 2nd and no drive just rev for a couple of seconds then pick up the drive. So changed the solenoids new oil to now i have 3 major problems ist is when i plug in the Peugeot diagnostics it wont read the gearbox ecu saying no com's to gearbox 2nd& 3nd is a fault coming up on the dash saying Speed control system faulty & ESP/ASR system faulty and they where not there before the solenoid change :mad::confused: attached 3 pic's i hope
OK UPDATE still can't get a signal from the al4 gearbox ECU iv checked every fuse at a lose now even checked the wiring :nono::mad:
 

Attachments

1 - 10 of 10 Posts
Top