Peugeot Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi, I have been the proud owner of my 2003 Peugeot 607 2.0 HDI for a little over 2 years now, I have put 60000 miles on it, serviced regular and now has a total of 129000 miles on it. Yesterday, I had a fault appear on the screen, ESP/ASR fault. The orange LED now also flashes on the switch. Any ideas? can this be as cheap as a fuse............?

Regards,

Batch.
 

·
Registered
Joined
·
1,002 Posts
Batch237 said:
Hi, I have been the proud owner of my 2003 Peugeot 607 2.0 HDI for a little over 2 years now, I have put 60000 miles on it, serviced regular and now has a total of 129000 miles on it. Yesterday, I had a fault appear on the screen, ESP/ASR fault. The orange LED now also flashes on the switch. Any ideas? can this be as cheap as a fuse............?

Regards,

Batch.
Hi and welcome to the forum,

ESP/ASR could be anything starting from the failure of fans to ESP sensors. The best way forward is to read the codes, I can check them for you if you tell me what the code is.

It could be nothing and all it might need is clearing the code.. so its just your luck mate... the thing is that ESP/ASR runs so many other circuits which is impossible to pin point exactly what caused the error.

good luck..
 

·
Registered
Joined
·
3 Posts
Hi all

Just joined the forum as I have found postings usefull in the past.

I now also have the ESP/ASR problem as descibed above on my 2002 607 HDi. My local garage serviced the car and then this error ocurred for the first time when I drove away from the garage. They say the error code is '488 can: connection with engine ecu' but are now stuck on what the problem is. They have checked for any loose connections that may have been caused during the service but so far with no luck. When the car is left overnight the warning does not appear when the car is started up next morning, but does then re occur after driving anyware between 4 and 19 miles. All very strange and annoying as the power is dramatically reduced when the waring light is on.

I also have the engine ecu light coming on and going off every 2 or 3 days with the codes P0246 - Turbo pressure, P1425 undocumented code and P1519 cooling function. This error has been occuring for a few weeks but does not affect the cars performance (or emmissions as it just passed the MOT) like the ESP/ASR waring does.Can anyone help with suggestions on the possible problems, particully with the ESP/ASR?

Many thanks.
 

·
Registered
Joined
·
1,002 Posts
your problem could be linked to one of the other forum members problem..

check Peugeot 2.2 thread.. and see if it would help..
 

·
Registered
Joined
·
3 Posts
Scotcruz said:
your problem could be linked to one of the other forum members problem..

check Peugeot 2.2 thread.. and see if it would help..

Thank's for the tip, but I cannot find a '2.2 thread', any chance of posting a link?

Many thanks
Pathfinder

Edit - OK - found it. Decided I have really no choice but to book in with a Peouget dealer and hope I don't get ripped off.
 

·
Registered
Joined
·
1,002 Posts
nae worries,

try and see if you could do it yourself..

it might not be a similar problem that manuel has... it would need investigation.. and you could save yourself a fortune..
 

·
Registered
Joined
·
3 Posts
Now all sorted. I took the car to a diesel engine specialist and they cleaned two sensers (one was the turbo boost apparently) that were 'gummed up' and this has solved the problem.

The first garage called in a so called Peugeot specialist who said the particle filter needed replacing and this could cost upwards of £1,000!!!! - Thank heavens I looked for a second opinion.
 

·
Registered
Joined
·
1,002 Posts
glad you got it sorted mate.. Im going through another saga with mine.. the brakes.. lol
 
1 - 9 of 9 Posts
Top