Peugeot Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Good evening all

I bought few weeks ago used 508. Today i got first problem.

Windscreen wipers went crazy and don't work any more. Right side wiper dont work at all and left side wiper is wipeing only small part of the window.
I removed battery minus cable for 20 minutes. When i connect minus cable, windscreen wipers worked some minutes perfectly, but then problem came back again.

I would be very happy and thankful if anyone could help me.

PS! Sorry, english is not my mother tong!

Many thanks and all the best!
Joosep
 

·
Moderator
Joined
·
5,115 Posts
Does the car have cheap xenon conversion fitted for headlights ?
Similar issue to the 407's fitted with aftermarket Hid's ???

Sent from my K013 using Tapatalk
 

·
Registered
Joined
·
26 Posts
I had a similar problem last year.

The passenger side motor burned out when the wiper got stuck to the screen with ice.

The 508 uses 2 motors and they communicate over the CAN bus to stay in sync and make sure they don't collide.

If one motor stops communicating then the other won't know it's location - it could be anywhere on the screen. So to avoid colliding, it will only wipe until the tip of the wiper reaches halfway across the screen. This causes it to only wipe 1/4 of the screen.

I got a replacement motor for £70 from an online parts dealer - you need to get the correct side - the left and right motors are different. (The dealer only sells them in pairs for £240 per motor + vat).

Replacement is easy enough - you need to remove the scuttle panel to get access and then it's 3 bolts and an electrical connector.

(put some silicone sealant under the scuttle panel when refitting to prevent water ingress to the engine bay).
 

·
Registered
Joined
·
1 Posts
I had a similar problem last year.

The passenger side motor burned out when the wiper got stuck to the screen with ice.

The 508 uses 2 motors and they communicate over the CAN bus to stay in sync and make sure they don't collide.

If one motor stops communicating then the other won't know it's location - it could be anywhere on the screen. So to avoid colliding, it will only wipe until the tip of the wiper reaches halfway across the screen. This causes it to only wipe 1/4 of the screen.

I got a replacement motor for £70 from an online parts dealer - you need to get the correct side - the left and right motors are different. (The dealer only sells them in pairs for £240 per motor + vat).

Replacement is easy enough - you need to remove the scuttle panel to get access and then it's 3 bolts and an electrical connector.

(put some silicone sealant under the scuttle panel when refitting to prevent water ingress to the engine bay).
I am currently having similar issue, nearside wiper won't move and offside is just wiping small section of windscreen.

I was quoted £475 for motors as they came as a pair.

I was also told that if I were to replace only the 1 motor that I would still need to get a garage to plug the car in and configure the motors.
Is this true or will a change over of the affected motor get this back up and running?

Thanks in advance.
 
1 - 7 of 7 Posts
Top