Peugeot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi Everyone,

I have a Peugeot 407 Hdi 2.7. I recently notice an issue about the auto transmission. Everytime after I drive a long time on highway or drive a long time at low speed in a parking lot, the auto transmission does not behavior very well. Basically, the auto transmission does not shift smoothly. But after driving on the local road a little bit, the transmission becomes normal. Is anyone have any idea what cause this and how to fix it. Thanks so much.

Cheers,
Fuyan
 

·
Registered
Joined
·
40 Posts
These boxes have a bad reputation for starting to fail around 70,000 miles, something to do with the galleries leaking inside the box, a very well known and common fault. A google Search will throw up all the info you need.

It may not be your problem, but it could be the early signs. A quick trip to a auto specialist may be worth while, or a quick plug in with PP2000 may throw up a fault code, but usually if there is a fault detected on the ecu for the box then sport and snow lights flash on the display. THIS DOES'NT APPLY IF THE GALLERIES ARE LEAKING INSIDE.

My Gearbox was replaced at 67,000 at a cost of £2200 . :eek:
 

·
Registered
Joined
·
2 Posts
You could try replacing the gearbox oil. But be warned you have to do it at least 3 time to get a high % of fresh oil in the box as you can only get 20-30% out at a time.

Sent from my SM-G925F using Tapatalk
 
1 - 3 of 3 Posts
Top