Peugeot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hi, I have a Peugeot 407 HDI 2 lit, 07 plate. Recently the car started cutting out randomly only after 10 to 15 miles journey approaching to a traffic light/round about/idle. When driving or raving the car is fine no problem what so ever. There are no warning lights appeared on DASH. Peugeot planet gives me a code:
P1351 (preheater relay-opening of relay even though not requested by ecu), problem with preheater relay. I have changed the relay and also the fuel filter but the problem still remained. I have deleted this code from ecu but every time the car cuts out it generates the same fault code which is now permanent. Any idea would be appreciated. Thanks
07799113317
 

Attachments

·
Registered
Joined
·
4,784 Posts
maybe a short in a wire that controls the relay, try unplug the relay and see what happens, if your car has no dpf then the glow plugs are not needed anyway
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
I don't know if my car has dpf, but I think it should do? What is the function of preheater replay? If I unplug it would it effect on car driving?
Could it be fuel pump? Although car still drives
 

·
Registered
Joined
·
4,784 Posts
pre heater relay puts glow plugs on but they are only used to regen dpf so as a test you could unplug but if you have dpf you can not leave unplugged all time

another thing to test would be battery and alternator as low or high voltage can cause strange things
 

·
Registered
Joined
·
20 Posts
When mine started cutting out for no reason with no warning lights it turned out to be crank position sensor which was only 20 odd quid.... ??
 

·
Registered
Joined
·
19 Posts
Discussion Starter #6
Hi same here mate, crank sensor changed and the problem gone. I took it to peugeot dealer and they did not find anything, burt charged me £60 ....wan****rs....Thanks for your reply though.
 
1 - 6 of 6 Posts
Top