Peugeot Forums banner

1 - 20 of 25 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hello every one I need sum help on changing a turbo on peugeot 407 2.0hdi
Im a mechanic and have this job to do at work tomoz I have it on the ramp and got the turbo shield off too at least get a clue to get it off but the pre cat is in the way
So I just wont sum help on the best way to change the turbo :)
 
D

·
Guest
Joined
·
0 Posts
Best of luck, its a nightmare.
You'll get most of it from up top. Remove the engine mounting on drivers side.
Whats up with it?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Best of luck, its a nightmare.
You'll get most of it from up top. Remove the engine mounting on drivers side.
Whats up with it?
I no it looks it lol dont no really boss just told me turbo gone it looks like oil seals.
Do I get the pre cat out from the top or is it from the bottom because it looks hard to get to any of the bolts
 
D

·
Guest
Joined
·
0 Posts
Get pre cat out the top. It's a bastard to line up again though when refitting.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Get pre cat out the top. It's a bastard to line up again though when refitting.
Cheers mate
So most of the stuff come from the top then
So engine mount off pull engine forwards then that prob make it a bit easy to work on lol because you cant really see the turbo from the top or bottom.. o the joys of being a mechanic ay lol
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Done the job to day and went well ended up taking the subframe off looked easier sum pics of the job from the bottom got the new turbo coming to moz I think so will take sum of prep and fitting work :)
 

Attachments

·
Registered
Joined
·
70 Posts
Hi pez, thanks for this excellant post.

Ive got the same 407 2.0 HDi with turbo problem. Can anyone help with my DIY job, unmounting the engine and puulling it forward. I got the idea from above. There are AC pipes between the radiator and the engine- these need to come out beforehand?

I'll upload some pics to show the engine room.

Cheers
 

·
Registered
Joined
·
15,377 Posts
It can be done from above on the 407 but If on a ramp removal of subframe is probably better as you can then get the cat back on a little easier but its still not a nice job :(

AC pipes can stay on unless you plan on removing rads to get engine forward not sure you need to though.
 

·
Registered
Joined
·
70 Posts
It can be done from above on the 407...
Thanks reliable406,

No enough room above, cant even see the turbo. I can jack up, leave the car on two stands and remove the sub frame underneath. For bolt removal I need to access from above. For this I need to bring the engine forward but dont wanna take off radiator, bumper and all that.

I need to disconnect the cat joint before pulling the engine I think.

Cheers
 

·
Registered
Joined
·
46 Posts
Done the job to day and went well ended up taking the subframe off looked easier sum pics of the job from the bottom got the new turbo coming to moz I think so will take sum of prep and fitting work :)
What is the function of this cable with connector on fifth picture,does it connect on the top of the engine near turbo solenoid valve. Once i touch something around it and lost turbo boost after that car "somethimes" not pulling like it should,can that be some wiring problems???
 

·
Registered
Joined
·
46 Posts
So that is electrical conection for acutator,i think my cable is thiner than this so maybe i have some wiring problems???
 

·
Registered
Joined
·
70 Posts
Most of the times MAP (mass air pressure) sensor get clogged up with carbon, leading to boost lost. Check that before checking the actuator connection.
 

·
Registered
Joined
·
70 Posts
It's fitted in the air intake unit. Please see the attached first pic. Also check MAF (mass air flow) sensor , which you can find right after air filter box, next to the battery- see second pic.


28ldp9c.jpg maf.JPG
 

·
Registered
Joined
·
46 Posts
I got some images:
Pic 1. This is the connector i wanna know what is for.
Pic 2.When i touch cable and pullit up like this than i got boost problem sometimes no boost at all,butwhen put it back down behind engine it is much better ,but not full 100%power
Pic 3. This pipe or cable is little oily sometimes is it normal or something is leaking but i dont know from where.This just under the place where is oil dipstick.??????
 

Attachments

·
Registered
Joined
·
46 Posts
I got some images:
Pic 1. This is the connector i wanna know what is for.
Pic 2.When i touch cable and pullit up like this than i got boost problem sometimes no boost at all,butwhen put it back down behind engine it is much better ,but not full 100%power
Pic 3. This pipe or cable is little oily sometimes is it normal or something is leaking but i dont know from where.This just under the place where is oil dipstick.??????
Anyone to explain this to me,please?
 
1 - 20 of 25 Posts
Top