Peugeot Forums banner

1 - 20 of 23 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
hiya we have been gave a 407 1.6 hdi to get running it went to a garage running all it had was a blowing injector then they did something and now the car wont go so it has come to us now we been playing for 2 month and still no go all injectors are seated correctly but it will just not register any fuel pressure using pug planet any ideas any one ???????
 
D

·
Guest
Joined
·
0 Posts
I have to say its hard to read something like that when theres no full stops etc.

Have you RPM? Cam/Crank sync?
What faults?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
hiya mate thanks for reply.
yes i have engine rpm on live data
i have cam/crank sync
i have replace the high pressure pump
replace the fuel pressure sensor
bought another ecu and had it program to the car
ecu not locked. immobiliser matched etc
only one code showing now which relates to the turbo pressure valve
when its cranking it is firing fuel straight down the return line. any ideas please? its asif its firing it down return before building any pressure
 
D

·
Guest
Joined
·
0 Posts
By any chance have you any fuel pipe unions open as you're cranking?
Have you trained in the injectors?
 

·
Registered
Joined
·
1,912 Posts
On the drivers side end of engine, level with the top, is an electrical connector. Just a feeling in my water, try disconnecting for a few seconds then reconnect: see if it helps.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
we have cranked the car while slackening injector pipes to make sure all air gone and its just diesel coming out and what u mean by trained the injectors ???
 

·
Registered
Joined
·
12 Posts
Discussion Starter #7
sterion75

what u mean by electrical connector we have had all plugs wires off the car sprayed everything with electrical cleaner checked all pinouts from ecu to every sensor and every one matches up
 
D

·
Guest
Joined
·
0 Posts
we have cranked the car while slackening injector pipes to make sure all air gone and its just diesel coming out and what u mean by trained the injectors ???
This is one of the reasons you have no fuel pressure, you're dumping it all out the opened union.
You have changed the pump right and the ecu. You need to train/code in the injectors into the new ecu.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #9
right even with the unions tight we still have nothing crank it over realy fast with engine boost and comes up with 8 bar
and if u mean program them i have tried that today but when i go on pug planet and try to program them says there shud be a 9 didget number and use the first 8 but when i look at the numbers that is ment to be programed to the car according to pug planet they like 04A02200 but when i look on the injectors none of the injectors have any numbers with letters
 
D

·
Guest
Joined
·
0 Posts
right even with the unions tight we still have nothing crank it over realy fast with engine boost and comes up with 8 bar
and if u mean program them i have tried that today but when i go on pug planet and try to program them says there shud be a 9 didget number and use the first 8 but when i look at the numbers that is ment to be programed to the car according to pug planet they like 04A02200 but when i look on the injectors none of the injectors have any numbers with letters
The number is on the outer edge of the injector.
You need to get the high pressure pump max pressure checked, regulated and unregulated. There is kit available to check this. A dealer should have it or a diesel specialist.
Have you done a leak off test on the injectors?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #11
right you say this number is on the outer edge do you mean on the top of injector... and yes we have they all returning the same and where would i be able to buy one of these kits or are they on ebay ??
 

·
Registered
Joined
·
9,733 Posts
Just look at the top of the injector and when you go to programme them in pp2000 will take you through it step by step, i find it easier to take a picture of the numbers before you put the injector in .
 

·
Registered
Joined
·
12 Posts
Discussion Starter #15
ye i done that iv wrote every number down of injector 1,2,3,4 and every number is same on every one about from there is two 4 digit numbers like one above other thats the only numbers that is diff but when i try to put those numbers in it says wrond code or something
 

·
Registered
Joined
·
9,733 Posts
on the top of the injectors there are two sets of numbers round the top of the injector , one set inside and one set outside , its the outer set closest to the rim and from memory its the first eight digits.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #17
well i have tryed the first eight digits there all numbers but still pug planet fails dunno if its cos the havent got a letter in like the ones that planet is saying its got programed
 
1 - 20 of 23 Posts
Top