Peugeot Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I've acquired an 09 Peugeot sport estate (yes I'm totally ignorant to car details.....but I know it's a silver car if this helps).
Anyway the car battery was draining, and the radio/sat nab system was dead. So I had a regular car electrician disconnect the head unit as he told me it was faulty. I've called Peugeot for help in replacing this, and fainted at their prices! Since this call I've tried a few auto electric company's and have been told this is a common fault with these head units and it can't be fixed. That I'm better off just buying a replacement radio and losing the sat nav system. Is this good advice? I know I could buy a replacement head unit off eBay but knowing my luck I'd buy another dead one.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
The head unit hasn't had power since I got it. The auto spark that looked at it (I've no idea how good he is), told me the fault draining the battery was simply that the head unit was faulty so he disconnected it. When I've called local auto electricians they've all informed me, given this info only, that it's best to buy a new head unit and lose the sat nav. As I live in a rural area I'm just trying to find out if this is the general thought process or if there's guys out there that might know better.
 

·
Moderator
Joined
·
3,760 Posts
HI....im suprised the sat.nav was draining the battery as with my 407 the car switches to economy mode if the voltage drops below a certain level and isolates all components.Can you be a bit more specific as to what has been checked ie..battery condition/age/..charging rate etc
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
As you can no doubt pick up....I'm pretty much dim to anything car related. But I'm always up for learning.
All I have is that when I got the car, the battery lasted a day or so and if I didn't use it....it was drained. Add to this is no radio, or any of the top two parts of the head unit. The lower unit works...well the doors lock/cigarette charger and stuff. But no parking sensors, I've read in the manual that this is off the same fuse? I pointed out to the auto spark that this was the issues. He told me the unit needed replaced. Since he disconnected the unit, the battery has been without any issues. Everything else is perfect (touch wood).
 

·
Registered
Joined
·
1,947 Posts
RT5, that's what I had in my last 407. It had the same colour seats as those in that picture too.

As noddy-hol says, they have "economy mode" which prevents the battery being too low to start the car.


They do have a habit of killing their hard drives. Not sure whether that would render the whole unit U/S though.
 

·
Registered
Joined
·
15,377 Posts
It WILL render the whole unit U/S to most people as they dont know HOW to fix it but it probably can be fixed but a good replacement unit will sort you out they are not that unreliable to be fair.

If you replace it the new unit needs vin coded to the car not a big deal but will need done.


Before doing that though i would get someone familiar with these units to check it over incase the real issue is with the car and disconnecting the head unit has simply broken a circuit.

Fitting an aftermarket unit is a backwards step in my opinion and you wont be able to set time etc
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
Would taking it into a Peugeot garage and having it checked on their computer help diagnose? And cheeky question - but would anybody have an idea of Any Scottish company that can have a look at it?
 

·
Moderator
Joined
·
5,090 Posts
Which bit of Scotland dawn ??

Sent from my K013 using Tapatalk
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
I'm in ayrshire but I'll gladly drive anywhere for some bloody music. It's that bad ha. I'm in both Glasgow and on the east coast regularly. So long as I'm driving to a competent person I'll go anywhere to get this darn thing fixed.
 

·
Registered
Joined
·
15,377 Posts
I dont have any real experience on the newer units only older ones but i could certainly give it a check over see if anything obvious is causing the issue or i could possibly code in a standard 407 radio to give you something for now but the facias of the ones i have are grey not black
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #15 ·
Noddy-hol I hope you don't try to predict the lottery numbers. Where's the offers that'll come flooding in..... haha.
If anyone could help please let me know.
 
1 - 15 of 15 Posts
Top