Peugeot Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Hi,

I posted previously about a fan heater not working and suspected the fan control module. My fan control module has black receptors for plugs and every spare 406 HDi I looked at had a fan control module with green receptors for plugs with the grooves for the plugs in slightly different places. I took one of these green ones home and I trimmed my plugs to make them fit.

Now the fan works BUT backwards. When the knob is on full the fan is off and when the knob is off the fan is on full and the speed varys as you move the knob, again opposite to what you would expect.

Does anyone know why this is? The original plug for the green connector has four wires as mine but one is in a different position and is a different colour
It may help if I understood what all the wires were for. One black negative, one red positive, in the same position on both plugs, one pink which seems to take the signal from the speed knob, again in same position on both, that is if pink is dong the same job on both. The old plug has a fourth wire, yellow, but this is brown on the plug for the new control module and in a different position.

What is the fourth wire for? AC?


Happy I have a fix but would like to understand this and maybe get the knob working correctly.

thanks

Barry
 

·
Registered
Joined
·
15,377 Posts
The resistor does the same job its just different versions years and trim levels had different set ups some have digital aircon some have no aircon some have manual aircon hence the different wiring
 
1 - 2 of 2 Posts
Top