Peugeot Forums banner

1 - 20 of 25 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi

I have a 406 peugeot cranking but not starting. Cheked with peugeot planet
engine paired with ecu imo unlock but strangely bsi unlocked - no. I wanted to reset the bsi and came up with strange message .please advise.
 

Attachments

·
Registered
Joined
·
15,377 Posts
You cannot do what you are trying to do without dealer access

More importantly your display of parameters looks correct to me the BSI is only unlocked during programming or downloading i believe.

WIRING is always the issue with these not electronics check the wiring under the front carpet and check earths
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Thanks for reply

I a little buffed from this car. Its a friend of my who took to me. The story goes that he prayed some water in the motor area for cleaning while motor was running. And the ac belt got wet and fell down. He took off the ecu wirings to have more room to fit it back. After that the engine started and he moved the car to another position, stoped it and never started again. When i hooked up the pp2000 bsi was locked but paired with engine management. I got the confidential code from dealer and unlocked the bsi and programed the two keys. everything works on the car just dont want to start. I cheked if itspumping diesel it is. The only strange thing is that when i tried to read the curent in the injection it was nothing coming to the plugs which are on the top . As i see the ecu should send those current impulses but nothing hapens on cranking. Thats why i think the injection is failing for now.
 

·
Registered
Joined
·
1,133 Posts
WIRING is always the issue with these not electronics check the wiring under the front carpet and check earths
THIS^^

Pay particular attention to the earths around the engine fuse box. Recently one of mine wouldn't start and it turned out to be a bad earth connection on one of the earth points hidden behind the fuse box. Cleaned up the contact surfaces and all good..

Another thing is to do live readings with PP2000 and check fuel pressure and cam/crank sync while cranking.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5 (Edited)
THIS^^

Pay particular attention to the earths around the engine fuse box. Recently one of mine wouldn't start and it turned out to be a bad earth connection on one of the earth points hidden behind the fuse box. Cleaned up the contact surfaces and all good..

Another thing is to do live readings with PP2000 and check fuel pressure and cam/crank sync while cranking.
Thanks for reply
No earth point found behind the engine fuses. Maybe because this is 406 restyled HDi 2.0
Tried to find all earth connections and clean them, also cleaned al plugs in the engine room, also cheked all the fuses one by one inside and outside
I tried to do some live data while cranking and cranc sync shows NO. Attaching some pictures on this
 

Attachments

·
Registered
Joined
·
15,377 Posts
Hose is drain for filter housing probably too big for a vac line but would not stop starting

No crank sync WILL stop starting check the timing belt but those readings are static you need LIVE readings ie while cranking
 

·
Registered
Joined
·
15,377 Posts
you dont need to save it you just need to check it

cranking speed ?
cam crank sync yes? no ?
fuel pressure ?

Thats all it needs to start everything else is gravy
 

·
Registered
Joined
·
15 Posts
Discussion Starter #11
i do it tomorow. But when i cranked cam crank sync was no fuel presure was over 100 if i remember right.speed was 0 also. but tomorow wil try to record it. Thanks for help
 

·
Registered
Joined
·
1,133 Posts
Remove the upper belt cover.

You also need to re-check your injectors once you have sorted the sync and got the engine to start as there is currently a massive difference in corrections.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #16
Thank you for helping

will check that probably in the weekend. Will come back with results afterwards.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #17
YES. You guys ar right. Timing belt was loose skiped tooth also when i insert bolt in the flywheel the upper timing spot at belt is of with 4 cm . So engine is total damaged i asume. The tensioner is loose i dont know what happened why but probably this is the reason why. Man im glad at this is not my car. Its a friend of mine who asked me to check it. Anyway you guys cracked the code :) . Big thanks for that.
 

·
Registered
Joined
·
15,377 Posts
DO NOT remove the head there is no need remove the rocker cover look inside you will see broken rockers ONLY remove camshaft replace the broken rockers rebuild engine WILL run easy fix i can do it in 2 hours
 

·
Registered
Joined
·
15 Posts
Discussion Starter #19
OK tried that but cannot bring both timings to position. One of them not posible to turn to place if the other one is fixed. I was wondering maybe something is bended inside the engine and wont let me rotate it to position.
 

·
Registered
Joined
·
15,377 Posts
No nothing is bent i guarantee that remove rocker cover and you will see broken rockers remove any loose parts 1 may be jamming a valve down.

Remove camshaft fit new rockers retime job done
 
1 - 20 of 25 Posts
Top