Peugeot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Engine temperature fault warning

Could anyone please advise on the following?
Struggling to get answers from mechanics in Melbourne Aust

"Engine temperature fault. Stop the engine" showing on the dash after warning ping sound and temperature dial swings to extreme right. The fans are not heard. The engine does not appear to be hot. After 45 seconds or so the temperature dial returns to normal (middle zone). Sometimes the temperature dial will not reset and the engine needs to turned off briefly to reset dial.
This issue does not occur when travelling on freeways at 100km/hr, only occasionally as i approach traffic lights or slow down at intersections. The issue may not occur for days of 100"s kms but then may occur after driving only 500 meters!
The temperature sensor has been replaced by Peugeot specialist a few days ago but the issue has immediately returned!
Please help/advise
Cheers Therese
 

·
Moderator
Joined
·
3,760 Posts
hi...if its happening after only 500 meters i would be looking for a wiring fault or maybe water ingress to the fuse box...gl though.
 

·
Registered
Joined
·
1,947 Posts
Could be the temperature sensor. There's a sticky detailing the symptoms and repair on the RCZ forum.

Sent from my Vodafone Smart ultra 6 using Tapatalk
 

·
Registered
Joined
·
1 Posts
Engine temperature fault warning

Could anyone please advise on the following?
Struggling to get answers from mechanics in Melbourne Aust

"Engine temperature fault. Stop the engine" showing on the dash after warning ping sound and temperature dial swings to extreme right. The fans are not heard. The engine does not appear to be hot. After 45 seconds or so the temperature dial returns to normal (middle zone). Sometimes the temperature dial will not reset and the engine needs to turned off briefly to reset dial.
This issue does not occur when travelling on freeways at 100km/hr, only occasionally as i approach traffic lights or slow down at intersections. The issue may not occur for days of 100"s kms but then may occur after driving only 500 meters!
The temperature sensor has been replaced by Peugeot specialist a few days ago but the issue has immediately returned!
Please help/advise
Cheers Therese
What was the cause of the problem ?
 

·
Moderator
Joined
·
8,215 Posts
I had a similar problem with my ds turned out the cooling fan had failed (motor burnt out).

Whenever I had to slow down once the car had warmed up and the temps started to rise when the ecu tried to switch on the fan it would not see the fan running signal so it would put temp gauge up to high and trigger engine fault message and the stop warning.

As soon as you stopped and started the car the gauge etc would go back to normal and all the warnings would go away until the next time.

I got the car home on the hottest day of the year by putting the heater and blower on full and driving home with the windows open

Sent from my SM-T830 using Tapatalk
 
1 - 6 of 6 Posts
Top