Peugeot Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Hi I have the 88kw Mini powered version , anti pollution fault comes up after driving on a highway trip. I have changed the plugs , the coil packs , then found out that the o2 sensor plug wasn't making contact fixed that then a new code reappears on my obd2 car scanner doctor P1339, says o2 sensor went in open loop during deceleration at 3250 rpm and water temp sensor read 102 deg celcius at that freeze frame , the car goes into limp mode musfiring then cutting out the electronic function readings on the obc. Ie the litres per 100 stops working and the fuel range goes up. I stop the car for a while then start it again then drives fine but with the eml apf light still showing, the next day the fan comes on now and then then the eml switches off and drives fine until the next highway trip the apf will come back again but never goes into apf around town. I noticed that after I clear the fault code P1339, when driving around in out hot summers the electric fan never comes on but temp gauge stays on half. ( fan only comes on when the eml light comes on )
The engine does have a rough idle ( car revs cleanly to 6500rpm without s misfire ) but the mechanic told me this is due to cylinders number 2 and 4 which showed 1000 and 800psi ( 1 and 3 showed 1300) on the compression test and told me the previous owners -mechanics never seated the exhaust valves correctly. I bought the car just after they had done the head over and head gasket as the car overheated with them due to a faulty radiator which was also replaced . Should I go to Peugeot to find out if they can pick up a faulty sensor or injector or should I rather get my compression sorted first by reseating the valves? Does my car run too hot or can it be a blocked cat convertor( the 02 sensors read rich voltages and I the exhaust does smell like paint thinners on idle ) any suggestions? I am from South Africa
 
1 - 1 of 1 Posts
Top