Peugeot Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
hi im in need of some help!!!!!!
ive got a 2003 peugeot 307 sw 2.0 hdi if i accelarate hard the turbo pushes me along fine but when i slow down for a junction the try and accelarate again the turbo dosnt work the car becomes very unresponsive if i pull over and leave the car for 5 mins and start again the car go's well again till i acelarate hard again and the back to the same problem any help or ideas would be very helpfull before i have to take it to the stealership with my hard earned cash :lol:
thanks in advance darren
 

·
Registered
Joined
·
2 Posts
a couple of questions?

1. Do you have a mulit functional display? if so does it show a message with engine fault on it?

2. have you noticed if the engine management light comes on?

3. when this problem shows up, if you try to rev the engine does it seem to rev to only 3000 rpm and then begin to become lumpy? if so is there black smoke coming out of the exhaust?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
hi thanks for the reply:thumb:
there is no warning on the multifuntion display and the engine managment light comes on when ignition is turned on but then go's off
as far as when the problem happens there is no black smoke at all
but the engine seems to rev to 3000rpm the as you said feels very sluggish and i have to change down a gear especially if going up hill also cant realy hear the turbo whistling either when this happens
 

·
Registered
Joined
·
2 Posts
ok from what i can make out it seems to me that it may be an EBC fault (Electronic Boost Control) or possibly an EGR fault (Exhaust Gas Recirulation) you need to get your car plugged into a diagnostic computer to see what is going on!!!:( it might be worth popping down to your local garage to see if they have a compatable system... if not it seems like a trip to peugeot!! :thumb:
 
1 - 5 of 5 Posts
Top