Peugeot Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi,
I have a 2002 307 sw 1.6l petrol
i have had the engine management light flash up at me aswell as 'antipollution fault' on the centre console.
the car will start and drive but will hesitate and judders at a certin point in the revs until i change gear again. it seems to start off a higher revs but the longer the car is run for the lower the revs are when the juddering kicks in.
I have plugged the car in this morning and got the following fault codes:
P0337 - RPM sensor
P1632 - alternator circuit malfunction
p1336 - ignition failure
p1337 - ignition failure cylinder 1
p1340 - ignition failure cylinder 4
p0300 - ignition failure
p0301 - ignition failure cylinder 1
p0304 - ignition failure cylinder 4

I did have the same problem about 6 months ago but am unsure what the codes were but a new coilpack dont the job and sorted it out. however i have changed the coilpack again this time but it has made no difference!!

Any ideas anyone?? :confused:

Thanks
 

·
Registered
Joined
·
4,778 Posts
Hi,
I have a 2002 307 sw 1.6l petrol
i have had the engine management light flash up at me aswell as 'antipollution fault' on the centre console.
the car will start and drive but will hesitate and judders at a certin point in the revs until i change gear again. it seems to start off a higher revs but the longer the car is run for the lower the revs are when the juddering kicks in.
I have plugged the car in this morning and got the following fault codes:
P0337 - RPM sensor
P1632 - alternator circuit malfunction
p1336 - ignition failure
p1337 - ignition failure cylinder 1
p1340 - ignition failure cylinder 4
p0300 - ignition failure
p0301 - ignition failure cylinder 1
p0304 - ignition failure cylinder 4

I did have the same problem about 6 months ago but am unsure what the codes were but a new coilpack dont the job and sorted it out. however i have changed the coilpack again this time but it has made no difference!!

Any ideas anyone?? :confused:

Thanks
try spray wd40 on ht leads and electrics and see if that makes a difference, also have alternator and battery tested this should be free at any car spares shops
 
1 - 2 of 2 Posts
Top