Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi everyone. I have a Peugeot 307 SE HDI Diesel 1.6 2006 plate on 97000 miles and am having some major problems. The car has been absolutely fine for months but a few weeks ago it said "de pollution fault" but within a couple of miles more driving it turnt itself off and the engine management light also disappeared!! I had it plugged in and nothing came up so just left it. 2 days ago I started the car first thing as usual and it said enguine oil pressure level low stop so I drove it around the corner and again it stopped and the light disappeared!! Now last night I was driving the car and all of a sudden it started loosing power and now feels like it doesn't have any real power at all and just cruises along. Any ideas? :(
 

·
Registered
Joined
·
92 Posts
I might be wrong but that sounds like the BSI computer might be faulty if it is triggering various errors. Just to check though, is the oil level within a good range?

With the loss of power, will the car reach 70MPH and will it rev freely towards the red, if not something may have triggered it into 'limp home mode'.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I've checked the oil and that seems absolutely fine. I drove it earlier and it was doing 60mph but that took ages to get up go and I was going kind of down hill but yes it revs freely it just feels like I'm driving a very old 1 litre will no real power....
 

·
Registered
Joined
·
1,805 Posts
You'll need live data and check for any stored fault codes on PP2000 or Diagbox.

We have the same model at work and it has a habit of being in limp mode without any EML etc.

Common faults are EGR sticking, turbo failing caused by oil blockages in the oil feed to the turbo.

How often has it had an oil change?
 
1 - 4 of 4 Posts
Top