Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi there, recently bought a very 2nd hand 307 wagon and have notced that the gear display on the dash shows an S then a * and blanks out and the car loses power. Not completely, but a noticeable lose of power. If I stopped the engine, then restart, it’s back to normal. Is this a safety mode and could it be as simple as replacing faulty electric valves? I would really appreciate any help. Cheers, VMCD.
 

·
Registered
Joined
·
1,953 Posts
Power loss is difficult to pin point. First we need full car details as to engine size, fuel it uses etc. Service history also helps. Then perhaps we can advise. We are not magicians but most of us has experience on cars. Help us to help you!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Hi, apologies, new to this whole forum thing. My 307 is a 3004 model, 2.0L engine, regular unleaded fuel. Unfortunately don’t have access to service history. It happened again today, driving when a sudden clunk sound, then on display panel the D (for drive) is replaced by s then * then it blanks out. Loss of power, not dramatic but noticeable. Shut down, restart and ok. Any assistance would be greatly appreciated. Cheers, VMCD.
 

·
Registered
Joined
·
1,109 Posts
From the symptoms you describe I suggest it may be a transmission electrical fault putting it into limp mode, presuming it's an automatic?.
If so then perhaps the services of a transmission specialist might be required.

Roger.
 
1 - 4 of 4 Posts
Top