Peugeot Forums banner

1 - 20 of 42 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
HI,

new to the forum and need some help please :)

a friend has a PEUGEOT 307 2.0 HDI TURBO on a 2003 with high mileage.the car is a non runner and he asked me to have a look at it for him unfortunatly it seems every tom dick and harry has got to it and had a go at fixing it :rolleyes:

the car turns over (battery was flat just charged it) but doesnt fire but it will run on easy start!! which indicates a fuel problem to me.i have looked under the car and it seems the fuel pump in the tank has been removed and proberbly has been put into a seperate diesel tank/supply to check its working there is allso a black plastic thing with fuel pipes going to it but cant see where it attaches to or where its from? plus the pipes are all disconnected! does anyone have a diagram so i can plum it all in correct?

any other things to check other than the pump by the fuel tank and the diesel pump in the engine bay? is there any fuel cut off valves or anything? i allso noticed the door key fob function doesnt work and the car radio is missing dont think that makes any diffrence but thought i would mention it

any help much appreciated :)
 

·
Registered
Joined
·
117 Posts
i think one of the first things that would be suggested is can you hook it up to planet and get a fault read done? if you say where you're based someone close-by may be able to help if you don't have it yourself. Or there's martin's map
 

·
Registered
Joined
·
9,733 Posts
Black plastic thing is an eloys tank , you need to find out more about that system before poking at that car, FAP filter could be blocked or a whole host of things, what lights are on the dash ? Diagnostics done?
 

·
Registered
Joined
·
32 Posts
Discussion Starter #4
i think one of the first things that would be suggested is can you hook it up to planet and get a fault read done? if you say where you're based someone close-by may be able to help if you don't have it yourself. Or there's martin's map
thanks for your help/reply much appreciated :)

i am in cornwall the nearest person looks to be trimmer - Bodmin, cornwall,

will it come up with all fault codes even if the car doesnt run?
 

·
Registered
Joined
·
32 Posts
Discussion Starter #5
thanks for your help much appreciated

i may have to go down the planet route good to know theres people out there that can help :)

i thought i would start with basics and undo the work thats been carried out i.e reconnect pipes etc and try basics and rule out the pumps anyone have a link or picture to the correct route/plumbing of theses fuel pips that fit on the tank pump etc?

a question about the fap filter, if it was blocked then the car wouldnt run on easy start but it does?? or am i missing something?

i read up about the fuel system what a weird set up and expensive to maintain!!

i will check what codes if any come up and get back to you all next week

again thanks for the help :)
 

·
Registered
Joined
·
673 Posts
i allso noticed the door key fob function doesnt work
Are you sure the key is even coded to the car....i may be wrong but if the key isn't coded to the car the fuel pump will be immobilised....when it's running on easy start, maybe thats all its running on....i may be well off with that but maybe it's worth looking into....how long does it run for on easy start?? is it a couple secs or does it carry on running. I would agree with afo that you need to hook it upto planet and find out whats happening....just a suggestion...hth :cool:
 

·
Registered
Joined
·
32 Posts
Discussion Starter #7
Are you sure the key is even coded to the car....i may be wrong but if the key isn't coded to the car the fuel pump will be immobilised....when it's running on easy start, maybe thats all its running on....i may be well off with that but maybe it's worth looking into....how long does it run for on easy start?? is it a couple secs or does it carry on running. I would agree with afo that you need to hook it upto planet and find out whats happening....just a suggestion...hth :cool:
hi,if the key wasnt coded to the car would the engine still turn over? how do i recode the key to the car? worth a try!.car runs only while there is easy start as soon as that runs out the car stops so defo fuel starvation problem
 

·
Registered
Joined
·
673 Posts
hi,if the key wasnt coded to the car would the engine still turn over? how do i recode the key to the car? worth a try!.car runs only while there is easy start as soon as that runs out the car stops so defo fuel starvation problem
Yes the engine would still turn over but the car would not start.....in the key there is a transponder that is coded to the car. without this the car is immobilised. The car can sometimes lose its code and the keys therefore will need to be recoded to the car. You need planet to recode the keys and im sure one of the fine lads on this site can get the code for you if you give them the vin or something....it only costs a few beers...:thumb: i aint no expert on this....betty (martin) seems to know quite alot about this your best off asking him....Remember this is just a suggestion and i might be well off.....hth...:cool:
 

·
Registered
Joined
·
32 Posts
Discussion Starter #9
ok,had a quick look at this car today.

fuel pumps working,fuel to injectors
checked all fuses,removed main fuse board and checked all connections and pins all ok.checked all fuses and ecu connections in engine bay all seems ok.

tried towing it to get it going no joy,but will run on easy start!

dash is saying anti pollution fault and airbag fault but cant see these causing it to not start?

ideally need to connect to planet,just trying to do all i can before taking it to the dealers.

any ideas?.thinking it could be the key lost its code or the ecu lost its code but fuel pump is working is that all it cuts of? or could be crankshaft sensor faulty?
 

·
Registered
Joined
·
673 Posts
ok,had a quick look at this car today.

fuel pumps working,fuel to injectors
checked all fuses,removed main fuse board and checked all connections and pins all ok.checked all fuses and ecu connections in engine bay all seems ok.

tried towing it to get it going no joy,but will run on easy start!

dash is saying anti pollution fault and airbag fault but cant see these causing it to not start?

ideally need to connect to planet,just trying to do all i can before taking it to the dealers.

any ideas?.thinking it could be the key lost its code or the ecu lost its code but fuel pump is working is that all it cuts of? or could be crankshaft sensor faulty?
where are you nedharris....??? :D
 

·
Registered
Joined
·
32 Posts
Discussion Starter #13
at the rear of the car on the underside someone has pulled out all the anti pollution parts,there still connected but all floating outside the tank,anti pollution light is on the dash.

would this stop the car from starting?
 
D

·
Guest
Joined
·
0 Posts
at the rear of the car on the underside someone has pulled out all the anti pollution parts,there still connected but all floating outside the tank,anti pollution light is on the dash.

would this stop the car from starting?
No, Get the ecu read. We'll go from there as they say!
 

·
Registered
Joined
·
32 Posts
Discussion Starter #15
thanks for the reply

being honest is it beeter for me to take the car to a dealers and get them to read the fault codes or buy the machine and have a go myself? i can always sell the machine afterwards to recoup the money? dealers would on charge me a 1 hr labour to plug in and read surely?
 

·
Registered
Joined
·
32 Posts
Discussion Starter #17
ok quick update,

i had someone from the forum come round and connect planet and had a few faults

think this is my first port of call/problem number one!

alot of the other faults are the filter problems all the pump etc is removed from tank and hanging down!

can anyone tell me whats needed to remove the faults? can anyone see any other problems why it woulnt start from these faults?

1.camshaft/crankshaft syncronisation,no camshaft sensor signal...i assume i need a new camshaft sensor and set it up correct with the right amount of distance 1.2mm???

2.differential exhaust pressure signal coherence of the differential pressure when stopped

3.additive pump

4.fuel filler cap present sensor fault

5.fuel gauge,low additive level sensor fault

6.additive injector fault

7.additive adding ecu fault

8.additive ecu

9.air bag seat belt deployment seat belt trigger on right open circuit

10. intermitant fault warning lamp general
 
1 - 20 of 42 Posts
Top