Peugeot Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1 (Edited)
Peugeot 307 1.6i(2006) is not starting(fuel pump failing?).

MY Peugeot 307 1.6i(2006) is not starting. It seems like there's no fuel going into the engine as the car turns over repeatedly but doesn't manage to fire up completely. I left the car for 15 minutes and then retried but without any success and repeated attempts also resulting in the battery running flat! The car definitely has enough fuel in the tank but this is an issue that seemed to present itself in the past week and this is the second occasion this has happened.

been reading elsewhere it maybe the fuel pump failing or cam shaft sensor.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #4 (Edited)
The battery had gone flat the week before, but that is because the car wouldn't start i think, oh, and the info display, time, cd, etc has been playing up, tx
 

·
Registered
Joined
·
1,805 Posts
If the battery has gone flat, the BSI may have been corrupted/wiped. It's not uncommon on the 307. The car can still turn over, but things like the key info could have been lost , so the immo won't allow the car to fire up, as well as ancillary functions like windows etc.

If so, it'll need programming on PP2000. Once your post count is up to 20, message someone
 

·
Registered
Joined
·
43 Posts
Discussion Starter #7
If the battery has gone flat, the BSI may have been corrupted/wiped. It's not uncommon on the 307. The car can still turn over, but things like the key info could have been lost , so the immo won't allow the car to fire up, as well as ancillary functions like windows etc.

If so, it'll need programming on PP2000. Once your post count is up to 20, message someone

Apparently the battery went flat because the car wouldn't start, is this correct, tx.
 

·
Registered
Joined
·
1,805 Posts
Had anything been changed on the car before it was a non-starter?

Have you checked the earths? Plugs?

Do the following;

Put the key in the ignition,
attempt to start the car,
switch the key to the off position
LEAVE THE KEY IN THE IGNITION
open the drivers door

Does the car beep 3 times?
 

·
Registered
Joined
·
43 Posts
Discussion Starter #9 (Edited)
Had anything been changed on the car before it was a non-starter?

Have you checked the earths? Plugs?

Do the following;

Put the key in the ignition,
attempt to start the car,
switch the key to the off position
LEAVE THE KEY IN THE IGNITION
open the drivers door

Does the car beep 3 times?
Right, we managed to get the car going but only by towing it and running down a hill, even then it was laboured, poor fuel management

friend thinks it may be engine management, ECU, but had similar probs with 206 awhile back, one time it was injector valve, next time it was spark plugs not firing, etc.

btw, been advised no PP contact in sheffield anymore, is this correct?

just remembered there was a bit of a on infrequent buring smell, last time it ran properly last week.
 

·
Registered
Joined
·
93 Posts
Right, we managed to get the car going but only by towing it and running down a hill, even then it was laboured, poor fuel management

friend thinks it may be engine management, ECU, but had similar probs with 206 awhile back, one time it was injector valve, next time it was spark plugs not firing, etc.

btw, been advised no PP contact in sheffield anymore, is this correct?

just remembered there was a bit of a on infrequent buring smell, last time it ran properly last week.
Have you tried taking the positive battary wire of for 15 minutes then put back on then try starting the car .

If that dont work ,check out the coil packs...

The brain, ecu lives near the battary see it it been rusted or water leaked if so put in a dry cuboard over night , dry it out , plug it back in then take negative wire of 15 minutes then try start agin ...

Must have full battery all above advise ...
 

·
Registered
Joined
·
43 Posts
Discussion Starter #11
Have you tried taking the positive battary wire of for 15 minutes then put back on then try starting the car .

If that dont work ,check out the coil packs...

The brain, ecu lives near the battary see it it been rusted or water leaked if so put in a dry cuboard over night , dry it out , plug it back in then take negative wire of 15 minutes then try start agin ...

Must have full battery all above advise ...
Just been advised when the car was drivgn down the hill the ECU light came on.
 

·
Registered
Joined
·
170 Posts
It really needs plugging into pp2000 to see whats going on. If you haven't got 20 posts yet there is a thread designed just for that. Either search for it or it should be within the links gibbo put.
 

·
Registered
Joined
·
43 Posts
Discussion Starter #13
It really needs plugging into pp2000 to see whats going on. If you haven't got 20 posts yet there is a thread designed just for that. Either search for it or it should be within the links gibbo put.
Hi, turns out no PP2000 in my area
 

·
Registered
Joined
·
43 Posts
Discussion Starter #16
Have you tried taking the positive battary wire of for 15 minutes then put back on then try starting the car .

If that dont work ,check out the coil packs...

The brain, ecu lives near the battary see it it been rusted or water leaked if so put in a dry cuboard over night , dry it out , plug it back in then take negative wire of 15 minutes then try start agin ...

Must have full battery all above advise ...

tx for info, we took it and towed it to a Dronfield Mech who has PP, they looked at it, says it has some electrical issues, that are causing occ short circuits, tripping the ECU and which puts it in a form of safe mode, another fault is draining the battery, still not repaired though, any ideas?

haven't got the PP codes yet.
 
1 - 20 of 22 Posts
Top