Peugeot Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1 (Edited)
Hi guys I have an issue with my car coming up with this message car will not start. It will try with a sniff of easy start. I have checked the engine relay back of the ecu the wire was corroded. I soldered another relay connector on it from a donor car. wires check out ok with multimeter. I tried to read with peugeot planet and when I do a global test . It test the centre locking and the airbags. But it will not talk to the ecu for some unknown reason. Ecu did not reply. Do I suspect I have a wiring fault. Or do I suspect the immobiliser is blocking peugeot planet from talking to the ecu. Forgot to add the fuel pump comes in. .this is been on going for month's. The engine code rhy on a 1999
I be great full for any info in where to start looking. Best regards jay.
Forgot to add. The way I got this code was from a cheap delphi unit which is limited. My peugeot planet works fine with other peugeot. What I cannot understand is how can my delphi scanner pick the code up but my diagbox/pp2000 version 7.58 won't strange. also I borrowed my friends snap on scanner and that gives the same code as the delphi
 

·
Registered
Joined
·
5,916 Posts
I've never had a 306 so don't know if it works the same as the later models but it sounds like it isn't recognising the key. The usual check is to try and start then turn the ignition off but do not remove the key. Open the drivers door and if the key is being recognised you should hear chiming. If it doesn't chime then the key isn't being recognised.

Have you replaced the key case recently ? If you have then did you move the immobiliser chip over to the new case ?

If you did move the chip or haven't replaced the key case then it may need the key reprogramming using PP200.
 

·
Registered
Joined
·
50 Posts
Discussion Starter #3
Good thinking batman regarding the chime come to think of it. I don't think I've ever heard it. I brought the car as a non runner. As I like my 306 and it was cheap. Regarding the rest planet wont talk to it only central locking and airbags. . It not had it key done. This is the story I got told. That car was running fine. Came to it next morning wouldent fire up. I will get back to you regarding the chime. Come to think of it . Every car I have ever owned always played that annoying chime when you leave your keys in
 

·
Registered
Joined
·
50 Posts
Discussion Starter #4
Hi guys I sorted the issue . It was the ecu at fault. I removed the little is of the board 5p08c3 disarmed the immobiliser and once I resoldered it back to the board it gave me access to peugeot planet. How ever it still wouldn't start. So I flashed the ecu with new software. And it fired up. This can be marked as solved now.
 

·
Registered
Joined
·
19 Posts
Interesting.

So you desoldered the immob chip and reflashed the ECU?

Can I ask how you reflashed the ECU? What did you use? KWP2000+? If so, where did you obtain the later ECU files from?
 

·
Registered
Joined
·
50 Posts
Discussion Starter #6
Hi my friend I have should still be able to get hold of the files for you. So as you know I respected flashed the immobiliser chip with an eprom reader and writer. After I resoldered it it allowed me access to the flash it self . I brought a cheap and cheer full mpps from eBay. Think it cost me about £20 the files I used was from a Peugeot 206 2.0l hdi I had given me the 306 and 206 share the same ecu. Inbox me your email address and I send them over to you
 
1 - 6 of 6 Posts
Top