Peugeot Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi!
I have a 2011 Peugeot 2011 that is struggling to start. I had this problem a year ago,it miraculously disappeared and is now back. I turn the key and it takes three plus attempts to turn over and I can hear a slight clicking noise. I have to put my foot on the accelerator and rev to prevent the engine from cutting out. When the car is warm it runs/starts no problem.

I had a service last week and the mechanic ran a diagnostic test on it and it showed no faults. I have had the battery and alternator tested, all in good order. The only other thing to mention is the thermostat shows warm when just starting the car- not sure if related?

Any suggestions would be helpful, my children are worried each morning if they are going to make it to school!

Thanks
 

·
Registered
Joined
·
227 Posts
Sounds like a faulty temperature sensor. If the temperature gauge is showing warm when the engine is cold then not enough fuel will be supplied to the engine to cold start it.
 

·
Registered
Joined
·
1,133 Posts
You need to have the battery load tested and check that the alternator is charging properly. Also remove/clean/replace the ground connections between the battery-body-engine.
These vehicles need a good battery to start and run properly, any low voltage/bad ground connections etc will cause the issues you are having.
The temp gauge reading may be pointing to a bad ground connection, so make sure these are all cleaned up.
 
1 - 3 of 3 Posts
Top