Peugeot Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi All Im new here and this might be quite a long post so please bear with me!
My 2007 Peugeot 207 went to my usual garage for its annual service and MOT back in March, was advised of an oil leak so agreed to have this fixed, i also wanted the cambelt changed as this was due a year or so ago (72k on the clock) so car went in all ok got the car back drove for 2 days fine then driving along at 60mph car went into limp mode and a system error came up, RAC kindly read the codes and said it may have just have been settling back after being taken apart, car went back to garage he agreed and cleared codes. Car was ok for a few weeks. then the car stalled at traffic lights but was fine once started but battery light was on so went straight to Halfords and got the battery changed as this was a note on MOT. Car was ok for another week then after driving 40ish miles car was slow, laggy and just no power behind it, so took it to my local garage again and his system couldnt read the car, so off it went to Peugeot, barely made it there before every warning light you can imagine came on and the car died. Peugeot diagnosed that i needed a new alternator - (i had gathered that from this forum thank you : ) ) so got my car back Thursday just gone and has driven lovely ever since no issues at all. Today how ever was driving 60mph and engine light came on with a depollution faulty error message, i drove home left the car for about 20 minutes turned ignition back and the fault is still there. I am really fed up as before this car went for its mot i have had no problems in the 9 years ive had this car. Is it time to call it quits and send it to the knackers yard!? Sorry again for long post!
Peugeot 207 1.4 90php 72k on the clock 2007 plate
 

·
Registered
Joined
·
123 Posts
What does it now drive like?

From looking through the forum the anti pollution warning could have many causes. It could even be a dirty air filter from the oil leak. I have the same error on my 2006 1.4 207 but in my case I have a oil leak, because the head gasket has blown, so all sorts is getting down the exhaust.

How did the garage cure the oil leak? What does it drive like?
Open the coolant cap. Does the coolant look dirty like oil is in it? Also open the engine oil cap and have a look at it. Is it just oil or is it mayo?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thanks for replying -
From looking through the forum the anti pollution warning could have many causes. It could even be a dirty air filter from the oil leak. I have the same error on my 2006 1.4 207 but in my case I have a oil leak, because the head gasket has blown, so all sorts is getting down the exhaust.

How did the garage cure the oil leak? What does it drive like? - renewed head gasket replaced cambelt and the alternator belt also drove fine after this but then became sluggish and laggy!!
Open the coolant cap. Does the coolant look dirty like oil is in it? Also open the engine oil cap and have a look at it. Is it just oil or is it mayo?
- coolant cap clean a bit of a murky pink but the coolant is pink - this was replaced at service in March! Engine oil cap is fine just oil, is it possible would this be a head gasket failure when i had it reskimmed (think thats the word) 6 weeks ago and the car has barely done 300 miles since? Ive had every error going in the past 6 weeks but this is a new one on me!:(

 

·
Moderator
Joined
·
2,968 Posts
Hi...you need to have the fault codes read by a dedicated code reader ..ie planet..perhaps there is a member near you who could help..Was the fuel filter changed at the last service..and have a search on here for 'water ingress' thats a suspect as well...ps cars dont need to 'settle' after work unless they are talking 'head bolts'...good luck and keep in touch..
 

·
Registered
Joined
·
123 Posts
You need to take it to someone with a odb2 scan tool. Maybe use the planet peugeot map if your garage cannot diagnose. The codes might locate the problem. Search anti pollution fault in the 207 forum there are loads of people with various solutions.

Sent from my SM-G930F using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Thanks for replying This seems to be such a generalised fault! Cars going back to Peugeot tomorrow just so frustrating I only got it back on Thursday and it’s going back again!!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Futher update- car went to peugeot they ran diaganostics again and said the car needed a new coil pack - misfire on cylinder 2 so this was replaced. I then had the car back for one day and it didnt feel right like it was taking a second to catch up to speed when changing gear. So past Wednesday it went back to the garage- my usual one this time and they said the cam sensor needs changing so got my car back after being away for the weekend i only picked my car up last night and now the rev counter isnt moving!!!! Is this usual with peugeots that after one issue you get another then another then another this surely cant be normal?! Sorry for the moan just really really fed up!!
 
1 - 9 of 9 Posts
Top