Peugeot Forums banner
1 - 7 of 7 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi.
Finished assembling my 307 1,6 Hdi that has been standing for some time. Changed camchain and cambelt. When trying
to start it up it won´t fire. Fuel to the injectors and everthing is timed perfectly but I get the errorcode P1351, preheating circuit malfunction.Cheecked all relays and fuses, earthpoints and everything else I could think of. Nothing strange anywhere... Also, the warninglight for oilpressure and battery does not light up and I can´t get in to the menu for setting the clock.
Anyone got some idea?
Thanks!
//T
 

· Registered
Peugeot 4007, 2013.
Joined
·
2,673 Posts
You can't check the relay for P1351 error without an oscilloscope, because it uses IC logic chip, but it isn't the issue for non start unless it is extremely cold temperature, ie: below or near zero degrees C. If the surrounding temp is the issue, then you need to replace the relay. YMMV, but I typically replace the glow plugs with the relay, not required but what I would do.

Maybe worth checking you did this correctly
BSI Reset / Battery Disconnection / Reconnection - French Car Forum

Needs live data reading with Planet
And doing this. Can you see the engine see RPM when cranking, etc ?
 

· Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
You can't check the relay for P1351 error without an oscilloscope, because it uses IC logic chip, but it isn't the issue for non start unless it is extremely cold temperature, ie: below or near zero degrees C. If the surrounding temp is the issue, then you need to replace the relay. YMMV, but I typically replace the glow plugs with the relay, not required but what I would do.

Maybe worth checking you did this correctly
BSI Reset / Battery Disconnection / Reconnection - French Car Forum



And doing this. Can the engine see RPM when cranking, etc ?
Thanks for your thoughts.
The car is in the garage (12 degrees c) and should not need much heating (I do get a very breef signal to the glowplugs) but it persists to complain about the P1351.
Will do the BSI-reset and see if that helps.
 

· Registered
Joined
·
1,867 Posts
Will do the BSI-reset and see if that helps.
That's probably worth trying. If can't adjust the clock you may have a BSI problem. This is one of the better sets of instructions to reset the BSI: https://frenchcarforum.co.uk/forum/viewtopic.php?t=61997

If the car is cranking at its normal speed the immobiliser may be active. Have you tried the beep test? Put the key in the ignition turn it On then OFF. Leave the key in the ignition and open the drivers door and listen for a warning beep. This will tell you if immobiliser is recognising the key.

What year is your 307. The original and facelift versions are quite different.
 
1 - 7 of 7 Posts
Top