Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi guys
2009 207 1.4 petrol.
Car had faulty alternator so replaced this (pattern part) and at same time fitted new battery.
Now charging steady at 14.5 volts on idle (14.3 with absolutely everything turned on) however I have fault code P0620 which wont clear. After erasing it comes straight back on even before starting engine.
No warning lights on dash and seems fine but code is a bit worrying.
Any ideas guys??
 

·
Registered
Joined
·
108 Posts
is the car running ok with no rough running ???

Any of these symptoms

Engine drivability issues
Engine stall when idling
Delayed engine cranking (especially when cold)
Other stored codes

Causes for this code may include:

Faulty PCM
PCM programming error
Open or shorted generator control circuit
Failed generator assembly
Insufficient control module ground(Earth)
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks for the input but none of that applies, car is running fine and battery is charging perfectly with no warning lights - just that one annoying fault code.
 

·
Registered
Joined
·
108 Posts
Still best to get it checked out, I wouldn’t dismiss any fault codes in the system just in case it develops into something more troublesome. As there is a suspect problem there with the code coming up all the time. ?
 

·
Registered
Joined
·
34 Posts
I had a similar issue, I found that the fault would reset first thing in the morning before starting the car, but would return shortly after. Also had the engine cooling fan running constantly when the engine was started, even from cold. It was throwing a fault about the bss controlled alternator network.

Long story short, found that the problem was the single plug connector (thin wire) that plugs into the alternator was not making proper contact. After repairing this issue has not returned.
 
1 - 5 of 5 Posts
Top