Peugeot Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter #1 (Edited)
Hi all,

Finally got my hands on Planet so I'm hoping for some advice on my faults if possible.

The faults are, loss of turbo boost under load and intermittent problems with starting. I've changed the glow plugs but not yet tested to see if the heater relay is working (need someone to listen for it in engine bay)

Checked my DPF load and it says 65% with last regen ~650km's ago. Additive levels are good.


Seems the turbo boost issue is something to do with the boost solenoid?

Can anyone with an expert eye make a conclusions from the planet screenshots?

Once I get these issues sorted I can de-fap it :)

Thanks in advance for any help,

PS. I've sorted the clutch and brake switch issues.

Ben
 

Attachments

·
Registered
Joined
·
115 Posts
Use the long USB cable and stick laptop on the fuse/relay box lid above the battery, press enter on all the tests and listern or feel with left hand, simples!

If you click on the info button of F6 (I think) it will give you more info on each code.
 

·
Registered
Joined
·
77 Posts
Discussion Starter #4 (Edited)
Cheers for the replies,

Cleared the codes and ran it up the dual carriageway to get the fault.

I think the clutch one is from turning the car off/on while moving when the cruise control was on.

Got the P2562 and a EGR one (p0490).

Car also did a regen recently and is currently at 5% load, atleast I know that system is working :thumb:
 

Attachments

·
Registered
Joined
·
77 Posts
Discussion Starter #6 (Edited)
No worries :)

My main issue is the damn P2562, driving around over Christmas was fine, but up in the hills of Yorkshire the turbo might cut out once or twice during a journey causing me to pull over and switch the engine off and on :(
 

·
Registered
Joined
·
1,073 Posts
Hi buuan

Did you ever get rid of the P2562 code?

I'm having the same, even though only intermittent and not registered as a permanent fault.

I also notice you too have a negative value on the turbo position repeat value, which I was under the belief that should at all times be a positive value, but not 100% sure about that.
 

·
Registered
Joined
·
586 Posts
Both of you have a look at the vacuum pipes just above the oil filter housing and then around the engine. The one above the housing will get roughed up when the filter is removed.
 
1 - 9 of 9 Posts
Top