Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I've had this code come up for the second time now p0087 fuel rail system pressure too low. I've changed all the camshaft and crankshaft sensor and new spark plugs but it's still misfiring sometimes when start it up the engine starts to shake a lot and it goes into limp mode as well. It also goes away when you turn the car off and on anyone could tell me what is could be thanks. ?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
When I start it up and the car is cold That's when the engine starts to shake really bad and if you tap the eccelerator it'll misfire. When you turn It of and back on most of time it'll run fine.
 

·
Registered
Joined
·
870 Posts
does sound like a fuel/air problem, those of us old enough to remember a manual choke will remember those symptoms.
But cant be more help where the problem is, could be anything from a dodgy sensor to a air leak.
try turning ignition on, then off then back on again to start the car. better/worse/the same?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #5
When it happens I turn it off the back on the problem goes away but sometimes I'll be driving and it'll go into limp mode then that code comes up p0087 . To me it seems like there's not enough petrol going to the injector
 

·
Registered
Joined
·
25 Posts
Discussion Starter #7
I've put shit loads of that in still no change I've swapped all spark plugs and changed cam and crankshaft sensors to.
 
1 - 8 of 8 Posts
Top