Peugeot Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi 207 16v 2007 year .
using car iSOFT diagnostics i970 I have 2 DTCs,
1.Variable Timing Electrovalve locked at upper stop.
2.Solenoid Control Valve anomaly (safety).
Car is running ok nothing showing on screen at start up.
I changed the Oil Pan and the oil.At start up the revs were at 1.700rpm
and after 4mins engine cut off.Started engine again and engine light came on.
drove for 3 miles and engine light went of.When I got home used i970 icarsoft to diagnose and got the 2 DTCs as above.I tried to delete the DTCs but they wont delete.I tried to take the valve out but it is stuck in and I cant get it out to clean it.I think the only way to get it out is with force and have to buy a new one any clues on how to get the correct one and where to buy it'
the engine is a 2007 16v ET3J4, wa-wc 1360cc.
Any help would be appreciated.John.(JONCON).
 

·
Registered
Joined
·
870 Posts
the solenoid valve can stick if worn, i would replace it. You will need to remove the air filter/housing and use a mirror to locate the single bolt, give it a good wiggle and it should slowly come out. No need to remove TB pipe on pic.



wouldnt hurt to take the front (exhaust) solenoid out to clean also.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3 (Edited)
Hi thanks for your quick reply,I can only find one valve on my engiine looking from front off car timing belt end..any ideas where I can get one,

I tried to attach a photo but didn't know how when it asked for a URL.
Regards John.
 

·
Registered
Joined
·
870 Posts
if your engine looks like this you probably need to remove air filter housing to see it (easy enough)
to remove the valve undo bolt and wiggle with pliers/water pump pliers and work out.
lift its electrical clip with your nail to pull wires off.
loads on ebay, keyword vanos solenoid dephaser valve

 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
It is the older engine its the ET3J4 1360cc WA-WC KFU engine.I still cant give you a photo as don't understand the url bit.
 

·
Registered
Joined
·
168 Posts
Well done on getting the photo up!

Remove the small bolt immediately to the right of the valve where it meets the cylinder head (literally between it and the coilpack). The body of the valve should then be able to rotate a little anti-clockwise or clockwise.

It's only held in place by that single small bolt and with an o-ring to seal it from leaking oil. Your engine looks nice and clean, the damn thing is surrounded in oil, so I'm surprised if you say it's stuck.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
I Took bolt out and swiveled it back and forward and tried to pull it out but it is still stuck solid from moving upwards.I then put WD 40 and moved it again hoping that it woul free it. Im leaving it for a day or two and then try again.
Also I took switch of and ran the car about 5 miles but did not notice any difference.i take from that it is not working.
Regards John
 

·
Registered
Joined
·
168 Posts
I Took bolt out and swiveled it back and forward and tried to pull it out but it is still stuck solid from moving upwards.I then put WD 40 and moved it again hoping that it woul free it. Im leaving it for a day or two and then try again.
Also I took switch of and ran the car about 5 miles but did not notice any difference.i take from that it is not working.
Regards John
Hi John,
If you can rotate the solenoid a little anti-clockwise and clockwise then I can assure you that the only thing that is holding it in is the friction of a rubber o-ring which isn't a lot.

If you have a replacement and you're not simply removing the thing to clean it then don't be afraid to use mole grips on it and prise it out. It wants to pull straight vertically out. Once to get mole grips on it then a little prising upwards WILL move it. Honest!
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
Hi scared to touch it till I get a replacement but I don't no the name of it or where to buy it can yoe help with this.
Regards John
 

·
Registered
Joined
·
870 Posts
if you remove the electrical plug you may see a number stamped onto the plastic, just google the number and take it from there.
 

·
Registered
Joined
·
168 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #14
Hi I have been on the wrong valve I have attached a picture showing where everything is and I was on No 1 which is the vehicle speed sensor.I should have been on No 16 the Variablr Timing Electrovalve, Its pouring rain at the moment but when it fairs up I will try and get it out,Ill let you know how I get on. Regards John.
 

Attachments

·
Registered
Joined
·
168 Posts
Here's the page from Peugeot Servicebox in which I've highlighted the part...

Not very helpful in showing where it goes of course! You just see it hovering there, lost in space, like some disembodied thing :)

 

·
Registered
Joined
·
8 Posts
Discussion Starter #16
Bought new 1920 gr electrovalve(thanks for the info).Took old one out---new one in and cleared DTCs.took for a drive and diagnostics does not bring up any DTCs.tested old one after cleaning and works(keep as spare).Thank you all for all your help,Glad I joined Peugeot Forum.Been a pleasure to have worked with you all
Regards JOHN.
 

·
Registered
Joined
·
168 Posts
Bought new 1920 gr electrovalve(thanks for the info).Took old one out---new one in and cleared DTCs.took for a drive and diagnostics does not bring up any DTCs.tested old one after cleaning and works(keep as spare).Thank you all for all your help,Glad I joined Peugeot Forum.Been a pleasure to have worked with you all
Regards JOHN.
Cheers John! Glad we could be of help. Our cars can be a bit baffling but there's enough brains on here that we won't be beaten!

:jedi:

Celebrate with a wee dram.
Regards,
Ivor
 
1 - 17 of 17 Posts
Top