Peugeot Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi,

I have a Peugeot 3008 1.6 BlueHDi Blue Lease Premium from 2017 with a mileage of 100k (bought it 2 months ago).

Last week when I was driving on the highway I got the pop-up: Problem with engine tempature, turn the car off (see picture), after turning the car off and on again the pop-up was gone and I continued driving. But after a few minutes the pop-up back and I noticed that when I went faster than 40 miles an hour the pop-up would show and when I lower my speed the pop-up would go away.

I brought the car to the garage and they read the on-board computer and based on that they put in a a new relais (part 1635676380).

Today I received the car back and first it seems to be fixed, but after 20 minutes on the highway I got the same pop-up again, what's new is that the engine cooling fans are blowing really hard after I turn the carr of (see/listen to video).

Is this a common problem and does anybody has any advice what the solution is.

Thanks in advance!

Thomas


Vehicle Speedometer Automotive tire Motor vehicle Car
 

·
Registered
Joined
·
66 Posts
First thing to check is sufficient clean cooling fluid. Second is that the temperature is overhot or not? If the temperature goes continuing above about 90degsC then this points to the thermostat or water pump. An IR temperature gun cheap on fleabay can be useful here by seeing the temperature around the thermostat housing compared to the radiator (top and bottom).
Also check connections to the temperature sensor plus the sensor itself. OBD2 logger should give you a reading on this.
Looks like the relay isn't the problem.
Last problem would be a failing head gasket, but unlikely.
Hope this helps.
 

·
Registered
Joined
·
271 Posts
Temperature looks high on the gauge in your picture. As the other guys have said, thermostat and water pump would be prime suspects on my list.
 
1 - 5 of 5 Posts
Top