Peugeot Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
Hi Guys
Have 57 plate 207 1.4 sport and am problems with oil pressure but only when hot, Under normal driving all is fine , But once oil is at 80+ when i come to junctions etc and revs back of i get Low oil pressure coming up on dash display,it goes of immediatley if i put 100 Rpm more on tick over but as soon as revs back down to idle all hell breaks loose again with alert coming back on;
Just had oil filter and oil change as i thought this might have been the cause Used Genuine MAN filter and Shell Helix 5W30 oil but still the same just done a 400 mile round trip to Gretna and back and only time it faultered was at lights again Has anyone on here had the same problem or know of a cure any advise or solution would be greatfully appreciated :cool: :cool:
 

·
Registered
Joined
·
1,424 Posts
this could be a faulty oil pressure switch And is 5/30 the right oil ?
 

·
Registered
Joined
·
32 Posts
Discussion Starter #3
Thanks for the reply Jagn the oil pressure switch has been replaced for a supossedly genuine part and oil is correct as far as i know 5w30 0r 5w40 is standard i believe ,its a mystery to me it runs like a dream other than that
 

·
Registered
Joined
·
876 Posts
9 times out of ten its a bad sensor, other than that check wiring, if all is good then check pipework, oil separator and pcv valve.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #5
Thanks for reply Stripe88 will change sensor over weekend as its probably the cheapest thing to start with would it be worthwhile having it hooked up to PP for diagnostics or wouldnt it show anything
 

·
Registered
Joined
·
362 Posts
I'd also check out if filter is well placed or not damaged, and it's cheaper...

recommended oil is 5w40, I've seen that other specifications sometimes causes false low pressure alarms.

hope it helps, erick
 

·
Registered
Joined
·
876 Posts
had loads and loads of cars but never had a oil pump go on me, if there are no strange noises and new switch doesnt work, it may be worth putting a pressure gauge in the sensor hole ( may be worth buying a compression tester,hit b&q if you need a smaller adapter)
you can google what pressure it should be.
 

·
Registered
Joined
·
15,377 Posts
If this is only happening when dropping to idle at junctions etc then it may be the ecu is not controlling the idle correctly rather than an oil pressure issue.

If the engine is idling a little to low then the oil pressure WILL be low we used to get it on the taxis when they were not running well.

I also recon 5/30 is too thin though.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #9
Many thanks for all the replies will try to get pressure test done ASAP regarding oil according to my book that came with car they recomend Total Quartz 5W30 so i did helix of same range idle does seem a little low at around 800-850 not sure what it should be will have to do some research once again thanks for replies
 

·
Registered
Joined
·
1,424 Posts
If your engine has a really high mileage I would put a 10/40 in which is what I use in my 307 Although a flickering oil warning light is acceptable on high mileage engines it can be worrying
 

·
Registered
Joined
·
32 Posts
Discussion Starter #11
Thanks for reply Jagn it only done 53000 so not really high milage might try some oil treatment to bulk oil up a little but not holding my breath for a quick fix
 
1 - 11 of 11 Posts
Top