Peugeot Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Just wanted to see if anyone can advise of the following...

1) I've had my car just over 6 weeks and it was last serviced in April. Last week it came up with a oil level warning and upon checking it was rather low; took around 1 1/2 litres to fill. I've been checking on and off and today it's back down to just over half full. There's no signs of a leak (nothing on the drive or parking space), no signs of smoke and no burning smells. Any ideas or suggestions?

2) A few days after getting the car, the brakes started making a loud 'horn' type of noise. It only happens when you're braking at low speeds and the harder you push the peddle, the louder the noise. It's not constant and I thought it was only happening after the car had been sitting for some time but that's no longer true and then it only seemed to happen in hot weather but again, that's no longer true either. The garage I brought it from have had it twice and can't find any issues and annoyingly, they say its never made the noise while they've been test driving it. The noise itself appears to radiate from the left front of the car but can't be 100%. I've got a video of the noise and will see if I can upload it tonight. Again, any ideas or suggestions would be appreciated.

The car itself is a 207 Sportium (2012), just over 48,000 and I've done just short of 2000 miles since purchase.
 

·
Moderator
Joined
·
6,264 Posts
Look through the wheels and see if the pads are worn for the noise as the first thing, then try a bit of hard braking in case the pads are just glazed.

If the engine is a VTI engine then early ones are known to use oil the official line is up to 1L per 1000 miles is acceptable/normal consumption for this engine.

My Daughter had a 207cc 1.6 VTI 120 and it used to drink oil with no visible smoke
 
1 - 2 of 2 Posts
Top