Peugeot Forums banner
1 - 17 of 17 Posts

· Registered
Joined
·
314 Posts
Discussion Starter · #1 · (Edited)
I've just put this on another thread but thought it might get missed so deserved one of its own. It's pretty useful for ordering the correct parts ( hopefully we won't need any just yet....)
The site is http://public.servicebox.peugeot.com/pages/index.jsp
You can change to the language you need on the bottom left. You need to sign up and on signing up you have to declare you're in the motor trade. Once you've signed up you can enter your VIN ( top left) and the all the information is specific for your car.
 

· Registered
Joined
·
683 Posts
I've just put this on another thread but thought it might get missed so deserved one of its own. It's pretty useful for ordering the correct parts ( hopefully we won't need any just yet....)
The site is public.servicebox.peugeot.com
You can change to the language you need on the bottom left. You need to sign up and on signing up you have to declare you're in the motor trade. Once you've signed up you can enter your VIN ( top left) and the all the information is specific for your car.
I am sure this is very useful, I cant see where you sign up to get a user name and password though. Peugeot Service Box
 

· Registered
Joined
·
486 Posts
I've just put this on another thread but thought it might get missed so deserved one of its own. It's pretty useful for ordering the correct parts ( hopefully we won't need any just yet....)
The site is Peugeot Service Box
You can change to the language you need on the bottom left. You need to sign up and on signing up you have to declare you're in the motor trade. Once you've signed up you can enter your VIN ( top left) and the all the information is specific for your car.
Same here. No 'Register' button. I use google chrome and internet explorer. both are same.
 

· Registered
Joined
·
1,302 Posts
Just tried it myself with Safari and it works fine, the registration box shows beneath connection.
However, if I try it again using Google's browser the registration box is not there.
The web page uses .jsp file extensions so it could be that either Chrome or whichever browser others are using is either not up to date or an extension is preventing the page loading fully.
Try opening Chrome using incognito mode. This allows you to not only browse in private but also disables your current extensions. :)
 

· Premium Member
Joined
·
5,121 Posts
works fine for me on chrome and like old pug ive been using it for years.
Another handy bit is put vin in the box then go to characteristics and you get full list of how the car left the factory
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top