Peugeot Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Hey All,

My 307 has just passed its MOT and only needed discs, pads and 2 bulbs... They obviously don't worry about the CV joint thats knackered and clicks as soon as you turn the steering...

Its now 110,000 (35,000 hard miles in the last 2 years)

However over the last few days I've noticed I sometimes lose my main beam if I go over a bump or use my indicator and sometimes even though I push the indicator up or down it doesnt actually flash - I've had loads of electrical gremlins over the last week, but by fitting the factory headunit again its all cured, except this headlight/indicator thing....

Could this be the stalk starting to fail - it currently has a bit of foam inside the cowling to make sure it pops back when it finishes flashing....

Any ideas?
 

·
Registered
Joined
·
4,777 Posts
Hey All,

My 307 has just passed its MOT and only needed discs, pads and 2 bulbs... They obviously don't worry about the CV joint thats knackered and clicks as soon as you turn the steering...

Its now 110,000 (35,000 hard miles in the last 2 years)

However over the last few days I've noticed I sometimes lose my main beam if I go over a bump or use my indicator and sometimes even though I push the indicator up or down it doesnt actually flash - I've had loads of electrical gremlins over the last week, but by fitting the factory headunit again its all cured, except this headlight/indicator thing....

Could this be the stalk starting to fail - it currently has a bit of foam inside the cowling to make sure it pops back when it finishes flashing....

Any ideas?
yes it could be but im sure I could fix it for you
 
1 - 2 of 2 Posts
Top