Peugeot Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Morning All
I am a newbie here and have searched around for answers before posting this. I have a 407 sw 2.2hdi 170 xs that since has decided that it has its engine light come on (depollution system error) and (economy mode activated).
Put a OBD11 reader on came up with 5 codes first time started up to get home now wont read again. The Original codes that came up were as follows:
0087 Low Fuel Pressure
0299 No Turbo Boost
0299p Under Boost Turbo
1351 Glow Plugs
1351p Glow Plugs/Relay
This Particular Car will be the death of me repair one thing something else crops up. Saying that i love the car anyone any ideas where to start with sorting this problem out as need to travel 40 miles a day for work.

thanks for reading.
 

·
Registered
Joined
·
15,377 Posts
The ONLY thing in that list that could be causing a non start is the low fuel pressure i recon you have wiring issues reading codes is not much help with diesels you need live data while cranking to find the fault
 

·
Registered
Joined
·
6 Posts
Hi h am no mechanic but I had an issue with depollution message it was the adective you have to top up its under the fuel tank. garage did it cos t£140 including the stuff. dont know if this helps.
 

·
Registered
Joined
·
15,377 Posts
His post says its not starting or at least thats what the title suggests lack of fluid wont stop it starting
 

·
Registered
Joined
·
6 Posts
No mine kept going but it said to stop luckily I was just passing my garage the booked it in and told me its ok to drive home2 miles, as I say I am no mechanic.
 
1 - 5 of 5 Posts
Top