Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 2001 peugeot partner ex post office van 1.9 the heater plug dashboard light stopped working and my van wouldnt start so i crossed the two terminals on the relay with a pair of mole grips to send a permanent live feed to the heater plugs. The van started but sounds noisy at low speeds. I tried a brand new relay £55 and it had no effect. Also the temperature gauge does not move at all My van sounds like a bus but it runs and at speed sounds normal. Not sure what to do next can Anyone help
 
D

·
Guest
Joined
·
0 Posts
What sort of noise, a diesel knock?
Get a diagnostic check done. The ecu only controls pretty much the injection advance only, but it can be read.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thanks for the reply. The sound is more like too much air is getting in not quite removing the exhaust but similar and yet when i put my hand over the end of the exhaust its sealed. Whats puzzling me is no temperature gauge no heat going to plugs and a throaty noise all on the breaking at the same time. I thought about the ECU will a diagnostic pin point the problem ?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Right ive had a diagnostic done and there were no results. Ive since had to replace the starter motor and heater plugs and was told to try the temperature sensor still no joy my van still sounds like a bus but it does still start. Im considering buying a new ECU but im put off by the price and the fact it may not be the problem. Also the mechanic used the phrase diesel knock if that helps. Id appreciate any feedback
 
D

·
Guest
Joined
·
0 Posts
Get the the valve timing checked also. something is upsetting the advace.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
I had an auto electrician take a look today he says that all three symptoms are related but hes not sure what is causing my van to sound noisy and have no heat or temperature gauge but that its definatly electrical. He offered to wire up a switch to give the heater plugs power On command but id like my van returned to its origional state than plaster one of the symptoms. Someone must have come across these problems before, can anyone offer any advice. Ive seen similar symptoms on other websites but no one posts a solution or can be contacted
 
1 - 8 of 8 Posts
Top