Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi, I have a 06 plate hdi gt which after a few days of ownership I discovered I had no horn, checked the fuse which was fine but I changed it anyway. found one fix on here which I was gonna try but I realised the alarm was also silent, the lights flash as they should...... so I'm guessing that the alarm is ok, the connection in the steering wheel isn't corroded but the horn itself has failed? I take it the standard alarm uses the horn to sound?
Thanks.
 

·
Registered
Joined
·
441 Posts
Ar least sounds(or not in this case:p ) like a common part after alarm / Horn switch, so could be control relay, wiring or horn irself...

I'd pull the connector off the horn and stick a meter / test light at the terminals of the connector. (or terminal to ground, if horn is grounded through body/mounting and it's just a single wire that connects.)
Could also verify horn alive/dead with temporary loose wires from battery/ground to horn terminal
 

·
Moderator
Joined
·
3,281 Posts
Yep..back to basics..check horn with a pos feed to horn direct from battery..
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Ar least sounds(or not in this case:p ) like a common part after alarm / Horn switch, so could be control relay, wiring or horn irself...

I'd pull the connector off the horn and stick a meter / test light at the terminals of the connector. (or terminal to ground, if horn is grounded through body/mounting and it's just a single wire that connects.)
Could also verify horn alive/dead with temporary loose wires from battery/ground to horn terminal
I'll give that a shot thanks, electrical problems..... oh happy days! Lmao

Sent from my SM-G955F using Tapatalk
 
1 - 4 of 4 Posts
Top