Peugeot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Signed up to this forum a couple of hours ago thinking it might prove useful one day, went to local shops and someone told me my brake lights are not working ..:eek:.
I'm sure they were working fine last night 'cos I kept seeing the brighter reflection when I hit the brakes in town.

I'm guessing/hoping its a fuse gone and wondered does the 307 come with spare fuses hidden away somewhere !?
If not, what kind of fuse do I need ?
 
D

·
Guest
Joined
·
0 Posts
Join pins 1 and 2 on the connector going onto the brake light switch, (passenger footwell) If doing this brings on the brake lights you need a brake light switch.
Very common problem. Oh disconnect the connector first before doing.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Finally got the car into garage and my mechanic tells me he ordered new brake light switch and it didn't fit !?
He called Peugeot and they tell him there is a new switch just been released to solve reliability problem .. hopefully getting it back today.
 

·
Registered
Joined
·
70 Posts
dont know if it will help, but my 3rd brake light and the right brake light went, i changed the fuse and it all worked again... the fuse that needed changing was a red 10 on in slot number 17... the fuse box is inside the glove box.
 
D

·
Guest
Joined
·
0 Posts
Finally got the car into garage and my mechanic tells me he ordered new brake light switch and it didn't fit !?
He called Peugeot and they tell him there is a new switch just been released to solve reliability problem .. hopefully getting it back today.
The new brake light switch comes with another length of wiring with it.
Its been out for ages.
I've fitted at least ten to 307s and c4's and no problems.
 

·
Registered
Joined
·
1 Posts
Brake light problem

My two rear brake lights don't work but the 3rd LED does. Also the Reg plate lights don't work. Any suggestions? I have pulled the connectors out and cleaned then reattached - no joy. I played around for a while longer and then they started working suddenly, but soon after they stopped again. The forum talks about an earth wire - can anyone explain in greater detail which one this is and why this can be at fault? there isn't a problem with the brake light switch, already checked that.
 
1 - 7 of 7 Posts
Top