Peugeot Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
291 Posts
Discussion Starter #1
Hi all

I have 2003 807 2.2HDi

Last night I lost all boost, no smoke, no noises, just no boost. Blanket is showing measured turbo pressure WAY below the reference figure, I'm assuming the turbo is fine due to the lack of smoke and noises. I know these 2 symptoms are not always the case.

I need some trouble shooting tips for checking the solo pods etc for the turbo to try and identify what the cause of the issue is.

Any ideas would be greatly appreciated.

Cheers
 

·
Registered
Joined
·
291 Posts
Discussion Starter #2
Live data info

At idle measures turbo pressure 988mbar, reference press 1098, when pulling away reference press goes up as expected but measured press actually goes down to 965
 

·
Registered
Joined
·
1,054 Posts
Is the eml on? Remove the large elbow by the lower right (looking to the rear)corner of the rad and confirm the turbo is gushing out air with the engine running. Check for a leak on the intake pipework. Check the operation of the swirl flap diaphragm on the right of the cylinder head, should smartly open when the revs are held above 2,000, increase revs rotating the throttle potentiometer under the wipers. Often they split causing a loss of vac which then throws the turbo solenoid into turmoil. Check the MAP sensor above the intercooler, there is small brass restrictor in the rubber tube that can get blocked.
 

·
Registered
Joined
·
291 Posts
Discussion Starter #4
No EML. I've checked pipe work and can't see any leaks/splits/holes etc. I'll check the things you mentioned and update

Thanks
 

·
Registered
Joined
·
291 Posts
Discussion Starter #5
Diaphragm is working, can't find the throttle potentiometer, I must admit i only had a quick look as was pressed for time, is it to central on the engine or to the left or right? Not getting any air gushing when revving either
 

·
Registered
Joined
·
291 Posts
Discussion Starter #6 (Edited)
Found the throttle potentiometer, can't see any pipes on it that might split

Can't see any brass fitting above the intercooler can only see small unit with a single thin rubber pipe going to it and some wiring, I'm assuming this is the MAP
 

·
Registered
Joined
·
291 Posts
Discussion Starter #7
This was a turbo failure, tried 2 garages to fix it, the first one started taking it apart then called to say he couldn't do it!!!!!! I'll not be taking my car there again.

The second garage was successful but did say it was a bitch of a job and the engine almost had to come out.

Sorted now though, working as it should.
 
1 - 7 of 7 Posts
Top