Peugeot Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
Hey guys, I have been browsing around for the last 2 weeks and decided that it is best to join and get answers from people that have experience.

Quick back story: New to driving, just passed in November and got my first car last month. I got a Peugeot (2008) 308 SE 1.6 Automatic from a Dealer in Peterborough. Unfortunately a day after i bought the car the management light came on saying "Depollution System Faulty". This disappeared on its own the same day and the light too. I tried to get the dealer to take the car back and recheck everything but he was being difficult. This issue happened again last week and I tried to contact them again but apparently they have now dissolved and won't get a reply off them. The issue went on its own again and the car was driving perfectly fine.

Two days ago my left rear indicator light stopped working so I bought a new bulb and changed it. Worked fine... the day after the same message and managment light came on. The same indicator worked for around 10 seconds than all the left rear lights stopped working now.

I used a diagnosis machine that I got off amazon and got these three codes:

P1338, P1340 and P1336.

Now obviously I am trying to avoid taking it in and spending so much on it aleady as I just bought it last month but I think it is obvious that I was screwed over by a deal.. so might have to suck it up and take it in :((((

Any advise from people who had the same issues? Is it somethig I can fix myself (more like my father in law he knows more about cars in general).

Thanks all
 

·
Registered
Joined
·
1,045 Posts
The Rear indicator is a fault with the earth do a search on here and you will find the fix its easy to for you or father in law,

next up your really better off getting the car on a Peugeot diagnostic computer as some of the basic ones will have you swaping bits after bits least with the Peugeot one you get live data more info on the fault ect.

ask to see if anyone here is in your area most will help out for a few beer vouchers.

P1338, P1340 is a Ignition Coil fault maybe coil pack spark fuse am not clued up on petrol cars

P1336 Crank / Cam Sensor fault

your better trying to get the computer on to see more info
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
Thanks

Thanks mate, I actually looked up a week or so ago but can not see anyone near or in the Cambridgeshire area? Unless I've searched wrong... If you direct me to where I can ask I would be very grateful.

With regards to the rear lights, my father in law managed to fix it but we also think it is the earth wire. However, the main connection plug from the car to the light circuit seems a bit knackered so I bought a new one to replace it and see if it works better.

The Rear indicator is a fault with the earth do a search on here and you will find the fix its easy to for you or father in law,

next up your really better off getting the car on a Peugeot diagnostic computer as some of the basic ones will have you swaping bits after bits least with the Peugeot one you get live data more info on the fault ect.

ask to see if anyone here is in your area most will help out for a few beer vouchers.

P1338, P1340 is a Ignition Coil fault maybe coil pack spark fuse am not clued up on petrol cars

P1336 Crank / Cam Sensor fault

your better trying to get the computer on to see more info
 

·
Moderator
Joined
·
6,301 Posts
Which engine VTI or normal 16V. If normal 16V check the plugs as some models can have issues if plugs are worn.

I read a 1007 the other day with missfire and cam sensor faults (No cam sensor on the engine). Told owner to try a new set of Bosch plugs (NGK can cause issues) and faults all cleared after a couple of journeys
 

·
Registered
Joined
·
1,928 Posts
Welcome to the world of cars and to the forum.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #6
It is a 1.6 (Peugeot 308 Hatchback (2007 - 2013) 1.6 THP SE 5d Auto (2008/08) If that means anything to you!! I shall look into the plugs.

The weird thing is I deleted the codes/management light off through the diagnosis tool I got off Amazon and the car was driving lovely since.. probably just luck!!

Which engine VTI or normal 16V. If normal 16V check the plugs as some models can have issues if plugs are worn.

I read a 1007 the other day with missfire and cam sensor faults (No cam sensor on the engine). Told owner to try a new set of Bosch plugs (NGK can cause issues) and faults all cleared after a couple of journeys
 

·
Registered
Joined
·
20 Posts
Discussion Starter #8
The odd thing is I deleted the codes and management light with the tool kit I got off Amazon and the car seems to be running perfectly now?? all lights are working too. Is that common? My father in law said maybe it kick started it whatever that means. I am not getting the depollution msg anymore...
 

·
Registered
Joined
·
3,467 Posts
Have you had an engine stall recently or tried to start it with a dead battery sometimes things like that throw up a fault


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
20 Posts
Discussion Starter #11
Hey mate, yes... the last 3 days when i switch my car on it goes on but you can tell something isn't quite right as it judders a bit then it goes off. I put it on again and it works a bit better but only if i put my foot on for a bit to rev it up :( I am waiting for the garage to let me know tomorrow about taking it in as they have been very busy with the snowy week we had.

Every time i get the code checked with my tool kit it says low fuel pressure... something is definitely not going to the engine right specially after a cold night.

Have you had an engine stall recently or tried to start it with a dead battery sometimes things like that throw up a fault


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2 Posts
Had problem with rear lights, on close inspection of the plug I could see one of the connections had at some point overheated therefore making a poor connection, difficult to find if your not looking...
 
1 - 13 of 13 Posts
Top