Peugeot Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
hi guys.
just got my hands on 99-t 406 110hdi. it has one or two issues if never dealt with before, and im not overly mechanically minded. i'll give owt a bash tho!!

1 - trip comp just says outside temp of 50-70 degrees c. button on wiper arm doesn't work. - any thoughts guys??? would love this to work. don't suppose having aftermarket stereo is an issue - no code for one in when I bought it.
2 - aircon flashes stop light on auto/ac but works on eco.
2 - rad fans not kicking in at 90 - flashing stop light came on. stuck in traffic at the time.

now the air con alters engine tone and relay click is heard, but at no point idling do either fan seem to work at all, gonna strip front panel off and see if I can find the relays and test fan.

My main question is are the aircon and fans problems linked??? or would a re-gas sort my aircon out???

I do appreciate any light shed on any of this!! love my pugs, just like them to work properly !!
 

·
Registered
Joined
·
1,026 Posts
Brilliant car, good choice ;) :thumb

I had a seized fan, and the most noticeable symptom was that the air con was rubbish at low speeds (because there was no air moving through the front of the car and the fan couldn't help).

There are two different fans fitted to that car, and on a T plate you will have the earlier one: the speeds are controlled by relays, and if the fan isn't seized then a duff relay is the most likely problem.
 
1 - 2 of 2 Posts
Top