Peugeot Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
127 Posts
Discussion Starter #1
Hi all

New 407 owner!! I recently bought a 407 coupe GT (2.7 HDI).

Lovely cruising car to drive!! 2006 model, red with white leather and only 34500 on the clock.

But.................... it's not without issues!!


1) High pressure power steering pipe popped!! Was losing a lot of fluid. Repaired under warranty. Fortunately the fracture/ split was on the straight metal tubing, just by the front axle so has now been repaired with a high pressure coupling. But i will need to source a replacement system at some point...............

2) Has got rear bump steer issues! Going over bumps at motorway speed makes the rear shimy to the right. Hopefully its just a question of rear suspension geometry re-alignment.

3) When unlocking the car - the hazards keep flashing. And they continue to do this until the engine is started. Not major, but bloody annoying now!!!

4) Low oil pressure warning!!!! Now i'm not sure this is completely genuine. This warning only comes on AFTER i've been driving for a while. And it only comes on when i've stopped, turned engine off, leave for a couple of mins, then re-start. Only happens on the warmed up re-start??

I think this is either a) an engine flush required. Low milage but only had two serives by previous owner. Or b) oil pressure sender is going U/S?

5) Front CD player is knackered!! Lucky the rear 6 CD unit is ok!!

If you've read this far then thank you!!! Any advice appreciated for issues 2,3,4!!

Otherwise the car is perfect?! :)
 

·
Registered
Joined
·
146 Posts
Welcome to the forum and glad you're happy with your purchase!
Hope you get the issues sorted & re the oil pressure low warning i would look carefully around the engine and ensure there are no oil leaks. Check the coolant for oil and oil filler cap for a thick creamy sludge (little is normal).

The front CD player only plays MP3's no WMDs or burnt CD's etc :thumb:

I have a coupe myself and i love it
 

·
Registered
Joined
·
127 Posts
Discussion Starter #3
Cheers Dave

Another coupe owner!!

Re: oil pressure low - i'm changing the oil in two weeks after BG244 routine. I'll see what difference that makes.

It is strange. I drove to London - 70 miles and no low oil warning at all. It only happens if i stop and turn off engine, wait 5 mins, then re-start? Warning on for aprx 2 secs then gone. I think at the moment its either low viscosity ( hence oil change) or pressure sender is going U/S?

Previous owner changed oil 3 times. Car has 35k, so oil changed every 2 years, not on mileage use.

I always change minimum once a year, if not twice!!! Especially if turbo driven!! Turbos break down that oil in no time.

Any one else had this? When warning does ping, i listen to engine. Nothing wrong. Revs hold steady, no metal grinding!!!!!
 

·
Registered
Joined
·
146 Posts
It's just the electrics i'm guessing, dont worry about it too much, get the oil sorted & have it flushed then go from there.

We had a 2.7 coupe on our forecourt for sale the other week, it was my demonstrator for 7 days until it got sold, lovely car especially for the money, the 2.7 engine is far more enjoyable than my 2.2 petrol :eek:
 

·
Registered
Joined
·
127 Posts
Discussion Starter #9 (Edited)
Haha!! I'll put some nice pics on once weather is better and it's had a good polish to bring out the shiny look!!

I have a pic in my email from when it was on autotrader but cant save it on laptop as a file to import here!!! Curse's!! Oh well, i'll get a pic on at the weekend.

A car wouldn't be normal for me if there wasn't something i could tinker with and fix!!! :D
 
1 - 11 of 11 Posts
Top