Peugeot Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi all,

New member here and recently collected a Peugeot 407 Coupe 2.2.
It has only 69k on the clock but I have a couple of questions for minor faults I have found.

1) boot button "0" doesn't work, but I found a split wire (blue) in the loom near the boot hinge. Temporarily connected it with a crimp but made no difference. There is another wire (brown) which appears to have been soldered but doesn't look great. Does anyone know the colour wire that I should be looking for and if the carpeted bit on the boot lid is straightforward to unclip so I can perhaps add a bit of slack to the loom on that entry for both damaged wires?

2) Can anybody tell me the rev limiter on this engine? I ask because mine cuts revs before the redline which is odd because allegedly peak power is 5850rpm and redline is 6000rpm. I wonder if this is a faulty coil or MAP or other. No warning lights.

Any help appreciated.

Thanks
Andy
 

·
Registered
Joined
·
893 Posts
Fault 1: Common fault on the 407 Coupe. Don't try to scrimp and save, do the job properly. Remove the entire loom (very easy to do) and replace EVERY wire where it passes through the rubber boot, literally replace a 30cm section in the middle of it, using solder and self-adhesive shrink over the wires to protect from elements.

It's straightforward to unclip the carpet on the boot, use your best judgement. Colour of wire doesn't matter, it's more about the thickness of the copper. It doesn't need "slack", it's just the wire wasn't designed to bend at the radius found in the loom, especially with the heat/cold cycles. I used Lapp Olflex 180 SiF but that's very difficult to get hold of, nip on to CPC farnell and buy some quality cable.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thank you for the detailed response regarding the loom. Where does it connect in the car? C pillar or under rear seats or something?

Also I guess my 2nd issue could be spark or coil related. Will start by trying plugs.

Thanks
 

·
Registered
Joined
·
893 Posts
Oh it's easy to find where it connects, open the boot, remove the left side piece of carpeting beside the tail light, connector is right there, just follow it from the rubber boot, you can't go wrong. There's only 5 wires in that loom, 2 are for power which are thicker than the other 3 wires.
 
1 - 4 of 4 Posts
Top