Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
my 2004 partner 2.0 lt HDI wouldn't start about 10 days ago , called out RAC, they diagnosed crankshaft position sensor fault-( this sensor was only replaced in march 2010 ) - so the crank sensor is duff again- it needs a new one
the following day its in the garage to have the new crank sensor fitted ( on jan 9th)- paid the bill and left...

for the next week all is good, running like a dream, sorted i thought....

today get in it drive 100 yards and the engine stalls, no warning lights, no beeping no engine management dash light nothing, - it struggled to start this time but it eventually gets going again, 200 yards further down the road the engine dies again, - turn the key and it starts easily now (as it has always done) but it wont keep running when ' under load' , it'l idle nicely but as soon as you press the accelerator and lift the clutch to pull away it stalls....

RAC sent a patrol out today who plugs in his basic roadside diagnostic tool and says no error codes come up-but he did say the peugeot diagnostics will show up the fault ?

he doesn't know whats up with it -so will stick it on a flat bed and recover the vehicle back to my address- but he says he reckons it might be the crank sensor playing up again !!!- surely it cant be duff again?

its had loads of sensors and regular servicing- whats up with the bloody thing ?

since owning the vehicle i have done 36,000 miles , in that time its had 2 crank sensors , 1 EGR valve unit and a new air mass sensor.... its covered less than 70,000 miles in its life.... surely its not normal to get through that many sensors in such a low mileage?
anyone got any ideas as to what this could be now ? its now doing my head in and the bills for the garage repairs and all the diagnostics are killing me...

anyone know what to look at first ?

thanks
 

·
Registered
Joined
·
4,506 Posts
the RAC fella is correct in saying peugeot diagnostics...find a local member using the link below that hold peugeot planet/diagbox. will cost you beer tokens (far cheaper than dealer and garages) you could even invest in diag set yourself for around £100

but to me if the crank sensor keeps going i would try and investigate why... also i would get the sensor fixed at your local dealer (take the cost) so if it goes again within the year your under parts warranty for that. :thumb:
 

·
Registered
Joined
·
263 Posts
If it does turn out to be crank sensor again, then maybe worth whipping off the gearbox and seeing what the flywheel is like as pretty sure it will get the signal from that.
As far as im aware, the crank sensor is standard magnetic switch, so to keep killing them is highly unlikely
 

·
Registered
Joined
·
29 Posts
Discussion Starter #4
the RAC fella is correct in saying peugeot diagnostics...find a local member using the link below that hold peugeot planet/diagbox. will cost you beer tokens (far cheaper than dealer and garages) you could even invest in diag set yourself for around £100

but to me if the crank sensor keeps going i would try and investigate why... also i would get the sensor fixed at your local dealer (take the cost) so if it goes again within the year your under parts warranty for that. :thumb:
ok cheers, - looked on the planet map my nearest member is d3Ck4rd but its still a fair old treck, - going to take the sensor out clean it up and take it back and have it checked to see if it still senses or not- if it is knackered again then i know its worth investigating the flywheel issue some more-

thanks for your input folks

the other issue is i have no trustworth main dealer near me both pug dealerships within 20 miles of me have lost their franchises, only got WLMG in slough to deal with locally and i've been stung before plus its a fair way to have the motor towed to !
 

·
Registered
Joined
·
29 Posts
Discussion Starter #6
sensor removed and checked, its fully operative, refitted, and also checked wiring, all seems 100%-

been on diagnostics and no error codes showing-

now it will ilde but give it some beans and the stalling pattern is back, - it'l stall, - then it'll restart and idle but give it some revs and its dies again....

- totally fed up, dont know what else to do or to look for, its now in the service bay of a local indepoendent garage, - dont know what else to do,

it'l be in auto trader by the weekend.... not quite so much lion goes from strength to strength anymore.....:nono:
 
1 - 8 of 8 Posts
Top