Peugeot Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
204 Posts
Discussion Starter #1
Hi people, I have a 2002 Peugeot 307 petrol manual.
The clutch has been normal since I got the car, never gave me any problems at all.
I know it's a hydraulic clutch, not cable.

As I'm driving along today in 4th gear, I come to a junction. I put my foot on the clutch and it's very firm. I put it into first, lift the pedal to where the biting point usually is and nothing is there. I continue to lift it up and it bites right at the very top. Also when driving along, the clutch plates slip now and then. It's almost like something is blocking the plates engaging properly.

I've had Green Flag out and they have advised I need a new clutch. Priced at £40-£80. I can fit it myself.

Does anyone else think it's the clutch?
 

·
Registered
Joined
·
3,423 Posts
sounds like it. no matter what it needs to be stripped down.

if your not a confident mechanic i wouldnt attempt it myself

its hard work dont forget you need gearbox oil and driveshaft oil seals
 

·
Moderator
Joined
·
5,630 Posts
What engine do you have if it's a 2.0 110 HDI may also need a new dual mass flywheel
 

·
Registered
Joined
·
204 Posts
Discussion Starter #5
It's just a small 1.4 petrol. I've done many clutches in my time, on bigger cars. So this should be a piece of cake.

It's getting stripped on Saturday, either way there's something wrong. I've taken it as worn clutch and got an LUK one on order for tomorrow. While I've got it apart I might as well change it anyway.

Guess nobody has ever had it before? Took my chances and posted here in case anyone had before and figured it to be a twisted cable or a leaking cylinder or something.
 

·
Moderator
Joined
·
5,630 Posts
I would also get a release bearing (if not a three piece clutch kit) and input shaft sleeve/seal as these are often damaged/worn
 

·
Registered
Joined
·
3,423 Posts
the slave cylinder pushes the fork when you press the pedal. then the release bearing pushes the pressure plate

my clutch was fine but i was getting a cracking sound. when i stripped it pressure plate was damaged. this happened to my grandads 106 too
 
1 - 8 of 8 Posts
Top