Peugeot Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi,

Got multiple fault codes at once and thought that the problem might be with the charger. Checked the battery level and it was 6 V when car isn't running and a bit lower when the car was running.
For a few weeks some belt has made noise but it wasn't the main belt but the noise came from the right-hand-side of the motor. I couldn't locate any belts there. But as you know, the motor compartment is really full of stuff so maybe I just couldn't see the belt. Now the noise has gone and the electrical problems came after that.

So the problem might be the charger. Here are my alternatives
  • Dead battery
  • Loose charger belt
  • Charger is broken
What do you think? And what are the options to check which one is it? Where is the charger and its belt even located at?

As you may see from this post, I'm not handy with cars. Any help is appreciated.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
Hi,

Got multiple fault codes at once and thought that the problem might be with the charger. Checked the battery level and it was 6 V when car isn't running and a bit lower when the car was running.
For a few weeks some belt has made noise but it wasn't the main belt but the noise came from the right-hand-side of the motor. I couldn't locate any belts there. But as you know, the motor compartment is really full of stuff so maybe I just couldn't see the belt. Now the noise has gone and the electrical problems came after that.

So the problem might be the charger. Here are my alternatives
  • Dead battery
  • Loose charger belt
  • Charger is broken
What do you think? And what are the options to check which one is it? Where is the charger and its belt even located at?

As you may see from this post, I'm not handy with cars. Any help is appreciated.
The problem was with the charger. Problem solved.

Important notice! You have to remove the air-conditioning compressor (under the alternator) when you replace the alternator. I tried to reach the one final bolt from the wrong direction - from above. That was a dead-end and had to take the car to maintenance.
 
1 - 2 of 2 Posts
Top