Peugeot Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello!

I recently purchased a second-hand 206 cc, however, for some unknown reason the multifunction display is not working - along with the radio.

I was told on purchase about the radio not working, which was no issue as I planned to get it replaced to a unit which be compatible with USB and Bluetooth. However, I am at a loss over the display unit.

I went down to Halfords today where I know someone who replaced my fuses for me for free and checked to make sure that there were no obvious loose wires behind the radio to stop it working but nothing stuck out.

I have scoured the internet and only found one suggestion to what this now may be for the same issues I have: radio and multifunction display not working BUT power going to the radio as it takes and ejects a CD (so I guess it’s getting electric supply?) - I did what was suggested and removed the casing and unplugged / replugged the display in and still nothing.

Does anyone have any ideas over to what this may be?

I’m not very car savvy, so I hope this makes sense!

Thank you
Georgina
 

·
Moderator
Joined
·
12,817 Posts
The most common reason for the display not working is because a dishonest previous owner has disconnected it so it doesn't show warnings!
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Where would it be disconnected? I took it out yesterday and it was connected at the back - I disconnected and reconnected to test the one answer I found on another forum to a similar query.
 
1 - 3 of 3 Posts
Top